Bug 120055 - Can't change the tab on Line Dialog with keyboard
Summary: Can't change the tab on Line Dialog with keyboard
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.3
Keywords: accessibility, bibisected, bisected, regression
Depends on:
Blocks: a11y Dialog Shapes-Line
  Show dependency treegraph
 
Reported: 2018-09-22 15:23 UTC by Tamás Zolnai
Modified: 2019-01-22 07:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot about Area dialog showing how it looks like when the tab page label has the focus (18.27 KB, image/png)
2018-09-22 15:24 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2018-09-22 15:23:35 UTC
Description:
In general LO dialogs works on a way that all features can used by keyboard only. However in Line dialog we can't change the tab page (e.g. Line, Line Style, Arrow Styles), by TAB-ing to the label of the current tab page. In other dialogs (for example Area dialog) we can use TAB to move the focus to the label of the tab page and then use arrow keys to change the tab page, but this does not work in case of Line dialog.

Steps to Reproduce:
1. Open Writer
2. Insert a shape
3. Right click on shape -> Line...
4. Move the focus with TAB

Actual Results:
We can't move the focus to the tab page label using TAB key and so can't switch to a different tab page.

Expected Results:
Should work similar to other dialogs (see Area dialog) and we should be able to change the tab page with TAB and arrow keys


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tamás Zolnai 2018-09-22 15:24:55 UTC
Created attachment 145111 [details]
Screenshot about Area dialog showing how it looks like when the tab page label has the focus
Comment 2 BogdanB 2018-09-22 19:19:16 UTC
Confirm it on Version: 6.2.0.0.alpha0+
Build ID: 66232248ff55639052ddb76918d555e21dc9c46b
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-09-20_19:40:04
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded

Shape - Area - we can focus on another tab
Shape - Line - we can't change to another tab
Comment 3 Xisco Faulí 2018-09-25 10:32:03 UTC
Reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

but not in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)
Comment 4 Xisco Faulí 2018-10-01 17:41:53 UTC
Actually, this is a more recent regression.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3014e5f362c77c546452d45fcde96fcbae27235e

author	Caolán McNamara <caolanm@redhat.com>	2018-04-29 21:15:22 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-04-30 11:41:54 +0200
commit	3014e5f362c77c546452d45fcde96fcbae27235e (patch)
tree	afbefbd2f10bbf971dd52ea0732031ee009c3d30
parent	5e71673ae0bbd4c0c1b32a1269155b4cd2cb5f45 (diff)
hook up can-focus to ability to tab into the widget

Bisected with: bibisect-linux64-6.1

Adding Cc: to Caolán McNamara
Comment 5 Caolán McNamara 2018-10-02 08:05:01 UTC
the notebook should have can_focus of true
Comment 6 Commit Notification 2018-10-02 09:35:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fee3669a3395133a9e47ff2f0a96159cb3eefb89

tdf#120055 line dialog notebook should be can-focus

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2018-10-02 09:36:48 UTC
that should do it
Comment 8 Xisco Faulí 2018-10-02 14:08:44 UTC
Verified locally!

@Caolán, thanks for the quick fix!

Cherry-picked to 6.1 -> https://gerrit.libreoffice.org/#/c/61247/

Not reproduced in

Versió: 6.0.6.2
ID de la construcció: 1:6.0.6-0ubuntu0.16.04.1
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk2; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group
Comment 9 Commit Notification 2018-10-02 18:58:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c2ecb7eaa448f33162ce60154af207228ac05a8&h=libreoffice-6-1

tdf#120055 line dialog notebook should be can-focus

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.