Download it now!
Bug 120068 - Table Formatting is forgotten if I delete/add a column
Summary: Table Formatting is forgotten if I delete/add a column
Status: RESOLVED DUPLICATE of bug 126008
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2018-09-22 19:05 UTC by eichannie
Modified: 2019-07-19 10:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
video. can't confirm on linux, maybe only windows (1.20 MB, video/mp4)
2018-09-22 19:34 UTC, BogdanB
Details
Example file (10.05 KB, application/vnd.oasis.opendocument.text)
2018-09-22 20:00 UTC, Telesto
Details
Old document which table which lost formattings in new versions (134.28 KB, application/vnd.oasis.opendocument.text)
2019-07-01 09:20 UTC, mini-matze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eichannie 2018-09-22 19:05:55 UTC
Description:
Settings like bold print or italics are deleted when a table is edited by adding or deleting a column. Font is also set back to standard when the table is edited.

Steps to Reproduce:
1. Create a table.
2. Format it with settings like bold print or italics
3. Add a column.

Actual Results:
Format is set back to standard.

Expected Results:
Format should not be affected by adding or deleting a column.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 BogdanB 2018-09-22 19:34:11 UTC
Created attachment 145120 [details]
video. can't confirm on linux, maybe only windows

Can NOT confirm it on linux. Maybe it's just a windows only bug. See the video.
Version: 6.2.0.0.alpha0+
Build ID: 66232248ff55639052ddb76918d555e21dc9c46b
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-09-20_19:40:04
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 2 Telesto 2018-09-22 20:00:07 UTC
Created attachment 145122 [details]
Example file

Repro
Version: 6.2.0.0.alpha0+
Build ID: d5a2202f955657e427670a87c2d4e5638884517b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-12_02:38:23
Locale: nl-NL (nl_NL); Calc: CL

STR
1. Open the attached file
2. Insert a column into the table
Comment 3 Telesto 2018-09-22 20:01:38 UTC
But not with
Versie: 6.1.0.2
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 Telesto 2018-09-22 21:17:39 UTC
@Jim
Sorry, again a lovely table formatting issue; the never ending story.. :‑(.
Comment 5 Jim Raykowski 2018-09-23 02:46:18 UTC
If the table has an autoformat style, as the table in Example file does, Simple List Shaded, the table style will replace all direct formatting on any row or column delete or insert. This was implemented by the following commit:

---

commit 73f4a06c0bce51c7c8b9ae9adfdc7ffac27d06b4
Author: Jan Holesovsky <kendy@collabora.com>, Sat Sep 26 17:55:31 2015 +0200 (3 years ago)
Committer: Jan Holesovsky <kendy@collabora.com>, Sun Sep 27 22:48:21 2015 +0200 (3 years ago)
Follows: libreoffice-5-0-branch-point
Precedes: libreoffice-5.1.0.0.alpha1
Branches: <Expand>

sw table styles: Insert column, split table, delete row/column.

Make these operations applying the table style too.

Change-Id: Iee2808a5a5c5f84538474b8fbc6bf53d1fab19b7 

---

I did submit a way to keep direct formatting and persist it with the following two patches but was reviewed as being a work around so I abandoned it.
https://gerrit.libreoffice.org/#/c/50612/
https://gerrit.libreoffice.org/#/c/51990/
Comment 6 mini-matze 2019-07-01 09:17:54 UTC
I think I have the same bug in another document, but I tried a few portable versions to find the version which got the regression, because old ones (4.x) could edit the table without problems. An this version is not 5.1.0.0 like described in the last comments. So it's possible to be an unique problem/bug?!

The last working version which could open and edit my document was v5.2.7.2.
The first version which could not edit the table without removing the formatting was 5.3.0.3 (but I could not test 5.3.0.0-5.3.0.2, because no portable versions exists for this versions).

I could not reproduce it with actual versions. It seems to be a problem with old documents and new libreoffice versions.

Steps to test:
1. Open my document (under Windows)
2. Click inside the table in same row
3. Add or delete a row
Comment 7 mini-matze 2019-07-01 09:20:22 UTC
Created attachment 152480 [details]
Old document which table which lost formattings in new versions

Before editing the text is formatted as "Arial, 9pt" - after editing it's "Liberation Serif,12pt" on my computers.
Comment 8 Harald Koester 2019-07-19 10:44:05 UTC

*** This bug has been marked as a duplicate of bug 126008 ***