Download it now!
Bug 120087 - Disable unuseable items on Manage Condition Formatting dialog
Summary: Disable unuseable items on Manage Condition Formatting dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Abhyudaya Sharma
URL:
Whiteboard: target:6.2.0
Keywords: difficultyBeginner, easyHack, topicUI
Depends on:
Blocks: Conditional-Formatting-Managing
  Show dependency treegraph
 
Reported: 2018-09-23 11:12 UTC by Tamás Zolnai
Modified: 2018-10-15 18:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2018-09-23 11:12:50 UTC
Description:
In LO the general behavior of the dialogs that those dialog items which does not make sense to change in the actual dialog config, those items are disabled.
For example check border tap page on Format Cells dialog (Format -> Cells). There the shadow properties (distance, color) can not be changed until the user not select a shadow type first.
LO should behave similar on Manage Condition Formatting dialog and disable Edit and Remove buttons when nothing is selected (there is no item in the list), since in this case these buttons do nothing.


Steps to Reproduce:
1. Open Calc
2. Open Fomat -> Conditional -> Manage..
3. Check the dialog items's state

Actual Results:
The conditional formats list is empty, but the Edit and Remove items are still enable, however they does nothing when pushed.

Expected Results:
Edit and Remove button should be disabled when no item is selected.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2018-09-23 12:15:04 UTC
confirm in LO 6.1.2.1 on Windows 10
Comment 2 Tamás Zolnai 2018-09-30 12:53:37 UTC
Let's turn this into an easy hack. Some code pointer:
GUI descriptor file:
sc/uiconfig/scalc/ui/condformatmanager.ui
Code logic is here:
sc/source/ui/condformat/condformatmgr.cxx
Comment 3 Commit Notification 2018-10-15 18:21:16 UTC
Abhyudaya Sharma committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=401d1691468fb11281b4eaa290193b4e8ff871c3

tdf#120087 Disable unuseable items in Manage Dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.