Download it now!
Bug 120155 - CJK: when "Allow hanging punctuation" activated&used, insertion point appears before last punctuation.
Summary: CJK: when "Allow hanging punctuation" activated&used, insertion point appears...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2018-09-27 13:59 UTC by Jiero
Modified: 2019-08-20 16:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A sample with brief (11.13 KB, application/vnd.oasis.opendocument.text)
2018-09-27 14:03 UTC, Jiero
Details
Identical to first file but added text in Tradiontional Chinese and Japanese (13.10 KB, application/vnd.oasis.opendocument.text)
2018-09-27 14:16 UTC, Jiero
Details
Same sample with Comment #2, only changed the font to Noto Sans CJK (14.32 KB, application/vnd.oasis.opendocument.text)
2018-09-28 06:01 UTC, Naruhiko Ogasawara
Details
Same sample opening with LibreOffice 4.0 Writer (266.34 KB, image/png)
2019-08-20 12:15 UTC, Franklin Weng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiero 2018-09-27 13:59:49 UTC
Description:
attached a bug-related file,  insertion point appears ahead of last punctuation. To see the problem, press end key which designed to bring insertion point to very end of current line. Simplified Chinese

Steps to Reproduce:
1.Find one sentence end with compressed punctuation;
2.Press End and it appears insertion point in wrong place.

Actual Results:
Insertion point never appear at the end if the punctuation was compressed.

Expected Results:
Insertion point with symbol of changing line or appear at the end. 


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Jiero 2018-09-27 14:03:00 UTC
Created attachment 145216 [details]
A sample with brief
Comment 2 Jiero 2018-09-27 14:16:15 UTC
Created attachment 145217 [details]
Identical to first file but added text in Tradiontional Chinese and Japanese
Comment 3 Naruhiko Ogasawara 2018-09-28 06:01:16 UTC
Created attachment 145240 [details]
Same sample with Comment #2, only changed the font to Noto Sans CJK

I saw that problem, with Noto Sans CJK (see attached)

And it seems to be caused if the last punctuation is "hanging," with Paragraph setting "Asian Typography," "Allow hanging punctuation."
Comment 4 Naruhiko Ogasawara 2018-09-28 06:03:08 UTC
Version: 6.2.0.0.alpha0+
Build ID: d077b30dba618daace0373e9b7e7fe84f982c6aa
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-26_23:17:55
Locale: ja-JP (ja_JP.UTF-8); Calc: threaded
Comment 5 Jiero 2018-09-28 07:05:27 UTC
Changed title according more recent findings.
Comment 6 Buovjaga 2018-10-23 13:34:24 UTC
NEW per comment 3
Comment 7 Franklin Weng 2019-08-20 12:15:45 UTC
Created attachment 153532 [details]
Same sample opening with LibreOffice 4.0 Writer

I don't think it's a bug.

When enabling "allow hanging punctuation", the punctuation is actually displayed "outside" the right margin of the paragraph.  You can set the paragraph alignment to "Justified" to make it more clear.

Such behavior has been there since at least 3.6.7.2 (the earliest version I installed.  The attachment is screenshot opening with 4.0)
Comment 8 Franklin Weng 2019-08-20 12:17:14 UTC
Propose to change the status to NOTABUG.
Comment 9 Ming Hua 2019-08-20 16:07:31 UTC
I don't mind this bug being closed as NOTABUG (that's for developers to decide), however IMHO "this is the behavior since 3.6" isn't a strong rationale.

I've seen this behavior as well and have always been slightly annoyed by it.  If one presses left arrow key to find the end of a sentence to either correct the last character or the punctuation, there is always a point that pressing left arrow moves the insertion point from after the punctuation to before it, but the cursor doesn't seem to move at all, which is rather disorienting.