Bug 120160 - UI: Save, load and restore customization configuration (UI profile)
Summary: UI: Save, load and restore customization configuration (UI profile)
Status: RESOLVED DUPLICATE of bug 59493
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-27 15:19 UTC by Thomas Lendo
Modified: 2018-10-17 19:50 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-09-27 15:19:35 UTC
A completely new dialog or a new tab in the 'Customize' dialog can be introduced where the user can save, load and set back to default the whole customization that was done in the UI for each application or for a file (see 'Scope' in Tools > Customize > Menus > Scope) or for entire LibO at once.

Customization includes:
* menu changes
* toolbar changes (Notebookbar changes in the future)
* context menu changes
* keyboard shortcut changes
* presentation of the sidebar (open/closed/collapsed, which tab is open, width and position of sidebar)
* window size and position (fullscreen, maximized or left bound or centered on the screen or whatever)
as well as
* toolbar icon size (from Options > LibO > View)
* sidebar icon size (from Options > LibO > View)
* Notebookbar icon size (from Options > LibO > View)
* icon style (from Options > LibO > View)
* icons in menus (from Options > LibO > View)
* shortcuts in context menus (from Options > LibO > View)
* mouse positioning (from Options > LibO > View)
* middle mouse button (from Options > LibO > View)
* font list preview (from Options > LibO > View)
* Theme (from Options > LibO > Personalization)
* UI language (from Options > Language Settings > Languages)
* extended tips (from Options > LibO > General)
and maybe other visual settings.

This feature could be used as a 'UI profile' and would make it easier for users to take UI customizations to another LibO installation or to share a profile.

To avoid the problem of UI elements for non-existing commands (if an existing command changed or was deprecated) or that new commands would be overwritten and made invisible by importing an old profile, the most optimal way to save such UI profile is to save only the changed elements instead of the whole structure. (For example, if a user adds an command to a context menu, not the entire context menu structure should be saved in the profile but only the added command with information at which position it was inserted.)
Comment 1 Thomas Lendo 2018-10-17 19:50:26 UTC

*** This bug has been marked as a duplicate of bug 59493 ***