Bug 120187 - Error message handling checkbox criterion building Query in Design View
Summary: Error message handling checkbox criterion building Query in Design View
Status: RESOLVED DUPLICATE of bug 116893
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-28 18:57 UTC by zoomer1
Modified: 2018-10-10 08:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zoomer1 2018-09-28 18:57:12 UTC
Description:
I want to emphasize that this works in Ubuntu, but not in Windows 8.1 x64.
Say I have a checkbox field in my table called Cancelled.  I want the query to list all the cancelled items.  I put a "1" or "=1" in the criterion in the Cancelled column.
I get the following error message:
 The data content could not be loaded

firebird_sdbc error:
*Dynamic SQL Error
*SQL error code = -104
*Invalid usage of boolean expression
caused by
'isc_dsql_prepare'
Yet it works in Ubuntu.  I have no idea what the error message means.

Steps to Reproduce:
1.Set up query in design mode.
2.Put "1" 0r "=1" in Criterion for Cancelled (Boolean) field.
3.Run Query.

Actual Results:
I got the error message listed above.

Expected Results:
I expected the query to run and give me a list of cancelled items.
It does this in the Ubuntu version.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.1.2.1 (x64)
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 8; OS: Windows 6.3; UI render: default; 
Locale: en-CA (en_CA); Calc: CL
Comment 1 Julien Nabet 2018-09-29 20:46:01 UTC
Which type of database do you use? (embedded hsqldb, Mysql, other?)
Is the same odb file you open in Ubuntu and Windows?

Could you attach the odb file so we can give it a try?
Comment 2 zoomer1 2018-09-30 12:55:56 UTC
The database is a Firebird converted database.
No, the Ubuntu and Windows files are not the same, except in structure.

I think that the problem could be caused by a faulty Firebird conversion in Windows, as I had other problems with the database in Windows after conversion, which entailed recreating a form and tables.

I will not be uploading the database as I encountered an error when I tried to do so (something about prohibited characters).

Feel free to ask additional questions if necessary.

Thanks,

Allan
Comment 3 Xisco Faulí 2018-10-08 15:41:01 UTC
Would you mind attaching the original database before it got converted to firebird ?
Comment 4 zoomer1 2018-10-08 21:34:20 UTC
I don't have the original database in Windows anymore.  I thought that you guys knew what you were doing and I wouldn't have any problems so I never kept a copy, just converted to Firebird.
I also deleted the Firebird database in Windows and switched back to a HSQLDB engine where I have painstakingly recreated the database from printed report copies from the Ubuntu database and other previously printed copies.
This was somewhat difficult because of the "Label" bug in the Report Writer.
However, except for Report Writer, everything is working again.

It will be a long time before I switch to Firebird again.  I am currently considering switching to a paid DBMS.

What is this regression to version 6.0.7?  When will Report Writer be fixed?
Comment 5 Alex Thurgood 2018-10-10 07:35:22 UTC
(In reply to zoomer1 from comment #4)> 
> What is this regression to version 6.0.7?  When will Report Writer be fixed?

If you mean bug 119067, then it will be fixed when a developer gets around to fixing it.
Comment 6 Alex Thurgood 2018-10-10 07:42:34 UTC
@zoomer1 : without a test db, how are we supposed to even attempt to reproduce the problem you describe ? 

There are several ways to obtain the result that you wanted, but we are still none the wiser as to which one you used. How is your checkbox field bound to the table field definition ? What is the datatype you used in your original hsqldb-embedded ODB to define your boolean behaviour ?

For example, I could solve this by :

- using a BOOLEAN field, but with the caveats at:

http://hsqldb.org/doc/guide/sqlgeneral-chapt.html#sgc_boolean_type

- using a CHAR or VARCHAR field and testing for the presence or absence of the char string ;

- using a BIT field

etc, etc
Comment 7 Alex Thurgood 2018-10-10 08:01:55 UTC
This report appears to be a duplicate of bug 11689, marking as such.

*** This bug has been marked as a duplicate of bug 116893 ***