Bug 120214 - Grammatical gender concordance for "spell out" numbering feature
Summary: Grammatical gender concordance for "spell out" numbering feature
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2018-09-30 15:01 UTC by RGB
Modified: 2019-04-11 20:07 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RGB 2018-09-30 15:01:53 UTC
6.1 added a numbering schema that "spell out" numbers, providing cardinal or ordinal numbers. There is a limitation with this feature, though, when used in Latin based languages: grammar gender. 

I'll use Spanish as example, but the problem is also present in Italian.

Because of grammar gender concordance, in Spanish we need to use "[El] Capítulo Primero" (male), which works OK, but also "[La] Parte Primera" (female) which is currently not possible.

In Spanish there is also a particularity for "male" ordinals ending in -ro when there is an inversion:

"Capítulo Primero" turns into "Primer Capítulo"
"Capítulo Tercero" turns into "Tercer Capítulo"

That is, there is a truncation.

The present feature request is to ask for a way to cover these situations. From the user point of view, an implementation that just adds more items to the "Number" list is a good solution. Keeping the list as it is now but adding a couple of check boxes (one for gender, the other for "truncation") seems better, but I'm not sure where such check boxes should go.
Comment 1 Thomas Lendo 2018-10-14 06:33:15 UTC
Adding needsUXEval due to the last paragraph of the bug opener's comment.
Comment 2 Heiko Tietze 2019-04-11 12:28:40 UTC
A grammatical correct solution, eg. in German "Erste[s] Kapitel" vs. "Erste[r] Absatz", is likely not possible but can be done manually per B/N > Customize > After (of course not depending on the actual value in this case). So this ticket is a NOTOURBUG.

Besides the request we should add a numbering style for spelled out values to have, for example, "First Chapter", "Second Chapter" as a predefined option => bug 124608
Comment 3 RGB 2019-04-11 18:03:37 UTC
(In reply to Heiko Tietze from comment #2)
> A grammatical correct solution, eg. in German "Erste[s] Kapitel" vs.
> "Erste[r] Absatz", is likely not possible but can be done manually per B/N >
> Customize > After (of course not depending on the actual value in this
> case). So this ticket is a NOTOURBUG.
> 
> Besides the request we should add a numbering style for spelled out values
> to have, for example, "First Chapter", "Second Chapter" as a predefined
> option => bug 124608

Your "solution" is not valid for Spanish nor Italian. You know, there are more languages out there than English or German. So please, provide a valid reason to close this bug (if there is any) or reopen it.
Comment 4 Heiko Tietze 2019-04-11 19:27:40 UTC
(In reply to RGB from comment #3)
> Your "solution" is not valid for Spanish nor Italian. You know, there are
> more languages out there than English or German. So please, provide a valid
> reason to close this bug (if there is any) or reopen it.

Feel free to reopen yourself. My reason to close was that it's a) not our bug and b) too many variants and dependencies make a solution unlikely.
Comment 5 Roman Kuznetsov 2019-04-11 20:07:11 UTC
Laslo, what do you think about this?