Bug 120237 - HSQL to Firebird migration problem
Summary: HSQL to Firebird migration problem
Status: RESOLVED DUPLICATE of bug 116893
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-01 11:21 UTC by JFV
Modified: 2018-10-01 12:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
base de sorties vélo (419.93 KB, application/vnd.sun.xml.base)
2018-10-01 11:22 UTC, JFV
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JFV 2018-10-01 11:21:28 UTC
Description:
Bonjour
Lors de la migration base de données HSQL en Firebird, nombreuses incohérences dans les tables et surtout beaucoup erreurs dans requêtes.

Steps to Reproduce:
1.migrer base jointe vers Firebird
2.utiliser formulaire saisie = 13 erreurs correspondant à moyenne mensuelle
3.calcul moyenne sortie est toujours entière, pas de prise en compte des décimales

Actual Results:
base fonctionne parfaitement en versions HSQL intégrée

Expected Results:
base migrée fonctionnelle


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 JFV 2018-10-01 11:22:43 UTC
Created attachment 145293 [details]
base de sorties vélo
Comment 2 Alex Thurgood 2018-10-01 11:33:06 UTC
@JFV : bugzilla submission must be in English.
Comment 3 Alex Thurgood 2018-10-01 11:37:13 UTC
Translation of OP's original submission:

Upon migration of a HSQL database to Firebird, a number of inconsistencies are produced in the tables, and many errors in existing queries.

Steps to Reproduce:
1. Migrate an embedded hsqldb to firebird
2. use a form to enter data = 13 errors for the monthly average function
3. The calculation of average output always gives an integer, without taking account of any decimals
Comment 4 Alex Thurgood 2018-10-01 11:51:24 UTC
Table Year :
ID: INT(10) NOT NULL PRIMARY KEY AUTO_INCREMENT
Year: NUMERIC(50) NOT NULL
Kilometers: NUMERIC(50) NOT NULL
Average: NUMERIC(50) DECIMAL PLACES 2


Table Outings:
N°: INT(10) NOT NULL PRIMARY KEY AUTO_INCREMENT
Day: NUMERIC(100)
Month: VARCHAR(100)
Kilometers: DECIMAL(100,2)
Hours: NUMERIC(100)
Minutes: NUMERIC(100)

View TableOutings:
SELECT "Year", "Kilometers" FROM "Year"

View OutingTime:
SELECT "N°", "Minute" + "Minutes" "Total Outing Time" FROM ( SELECT "N°", "Hours", "Heures" * 60 "Minute", "Minutes" FROM "Outings" "Outings" ) "Outing Time in Hours"
Comment 5 Alex Thurgood 2018-10-01 12:08:47 UTC
Marking as DUPLICATE of bug 116893 for the migration of DECIMAL/NUMERIC fields, but the database is a prime example of all that is not working with the current migration, including some functions, time calculations, etc.

*** This bug has been marked as a duplicate of bug 116893 ***