Bug Hunting Session
Bug 120264 - Command to access the "Get Involved" page needed
Summary: Command to access the "Get Involved" page needed
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Help-Menu
  Show dependency treegraph
 
Reported: 2018-10-02 10:06 UTC by Heiko Tietze
Modified: 2018-10-16 20:47 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (94.48 KB, image/jpeg)
2018-10-12 17:01 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2018-10-02 10:06:56 UTC
We discussed the idea of access to "Get Involved" from the menu. That's also needed as it would be the only chance after the info bar message has been dismissed.

Part of this discussion is a catchy term. We have 

LibreOffice Help
What's this
User Guides
-
Get Help Online
Send Feedback
-
Restart in Safe Mode
-
Donate to LibreOffice
-
License Information
About LibreOffice

Some idea:

* Get Involved (advantage of being identical to the page name; will use this placed underneath Feedback in the patch)
* Join the community
* Participate in the project
* Contribution opportunities

Opinions?
Comment 1 Heiko Tietze 2018-10-02 10:23:08 UTC
Preliminary patch is at https://gerrit.libreoffice.org/#/c/61238/
Comment 2 sophie 2018-10-02 16:05:18 UTC
Hi Heiko, Get Involved is ok, already in the in the document bar. Maybe place it after Send Feedback to avoid the repetition of Get two times. Sophie
Comment 3 Mike Kaganski 2018-10-05 17:32:58 UTC
(In reply to Heiko Tietze from comment #0)
> it would be the only chance after the info bar message has been dismissed.

Reading the code in https://cgit.freedesktop.org/libreoffice/core/commit/?id=c3fa7a82b7657b00f30394df59e2ffc610350686, I get an impression that the infobar is expected to pop up every 30 days?
Comment 4 Heiko Tietze 2018-10-06 14:36:40 UTC
(In reply to Mike Kaganski from comment #3)
> (In reply to Heiko Tietze from comment #0)
> > it would be the only chance after the info bar message has been dismissed.
> 
> Reading the code in
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=c3fa7a82b7657b00f30394df59e2ffc610350686, I get an impression that the
> infobar is expected to pop up every 30 days?

So I'm not alone ;-). AFAIK, it was intended to never pop-up again after it was dismissed. Kendy, is that true?
Comment 5 Florian Effenberger 2018-10-08 08:41:53 UTC
Both "Get Involved" and "Join the community" sound good to me, although the former one is probably easier to translate. I'd put it above "Donate to LibreOffice". Just my two cents though :-)
Comment 6 Commit Notification 2018-10-09 14:10:41 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0aa9310299181cea87c5723a933ffd5ee4afe22

tdf#120264 - Access to "Get Involved"

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 BogdanB 2018-10-12 17:01:42 UTC
Created attachment 145659 [details]
screenshot

Verified. See the screenshot.

Version: 6.2.0.0.alpha0+
Build ID: 144da6d5079bcd435e6637cb5cf95305f3ec1306
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-10-12_02:13:01
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded