Bug 120277 - Special Character dialog doesn't appear in Online
Summary: Special Character dialog doesn't appear in Online
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice Online
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks: LOOL-Tunneled-Dialogs
  Show dependency treegraph
 
Reported: 2018-10-02 23:20 UTC by Aron Budea
Modified: 2019-02-03 05:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-10-02 23:20:09 UTC
I thought this bug had the same cause as bug 117784, but apparently not.

- Open a document in Online, and click Insert Special Character.

=> Nothing happens.


Alternatively, using gtktiledviewer:
- Start it from a core build like this:
  bin/run gtktiledviewer --lo-path=$PWD/instdir/program <ODT file with path>
- Click the rombus with question mark, and enter the following as UNO command, then click Execute: InsertSymbol

=> The dialog should appear, but nothing happens.

Observed using LO 6.2.0.0.alpha0+ build (b6429f3e72a705e41e1da6b6402bd7aba12ab11f) / Ubuntu 18.10.
No issue with oldest state of repo bibisect-linux-64-6.1.

Bibisected to the following commit using that repo. Adding Cc: Caolán McNamara, please take a look sometimes.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=374599f8c26713905a310673d2b429083321186a
author		Caolán McNamara <caolanm@redhat.com>	2018-03-22 13:41:50 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-03-30 14:32:12 +0200

weld SvxCharacterMap dialog
Comment 1 Caolán McNamara 2018-10-03 13:51:42 UTC
I think the problem is there was some magic smoke in SfxModalDialog which it used to inherit from
Comment 2 Commit Notification 2018-10-03 19:04:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=19ec881034dbabbdc72779eb9382d0deb17ac569

Related: tdf#120277 extract common piece of SfxModalDialog LOK notification

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2018-10-03 19:04:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=349d0e679a4ee296c703145afe73e65efc5d2bff

Resolves: tdf#120277 special character dialog not appearing in Online

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2018-10-03 19:05:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ca8558a28d1dc271cd2f10362e5e0f7d218149cb

Related: tdf#120277 inherit from SfxDialogController

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2018-10-03 19:07:40 UTC
gtktiledviewer works for me now, so I assume that's fixed
Comment 6 Aron Budea 2018-10-04 22:50:59 UTC
Verified, thanks for the fix, Caolán!

LOOLWSD master.. (git hash: 250ffe6f)
LOKit   LibreOfficeDev 6.2.0.0.alpha0 (git hash: 5f5d890)
Comment 7 Commit Notification 2018-10-31 09:26:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/86d477d0d823e2aafdf6f54149a62bbf54741001%5E%21

Related: tdf#120277 extract common piece of SfxModalDialog LOK notification

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-10-31 09:28:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/12ed60bc8cc391811b9447300b0d06bba8e18975%5E%21

Resolves: tdf#120277 special character dialog not appearing in Online

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-11-06 18:24:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/20826019d8f77129853712c5fdf5134aff058171%5E%21

Related: tdf#120277 inherit from SfxDialogController

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.