Download it now!
Bug 120305 - Copy and paste on Expert Configuration does not work as expected
Summary: Copy and paste on Expert Configuration does not work as expected
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog-Expert
  Show dependency treegraph
 
Reported: 2018-10-04 11:28 UTC by John Bester
Modified: 2018-10-16 17:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
video showing the bug (5.04 MB, video/mp4)
2018-10-04 16:20 UTC, BogdanB
Details
the good video (2.98 MB, video/mp4)
2018-10-04 16:23 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Bester 2018-10-04 11:28:29 UTC
Description:
Selecting text in export configuration setting and then using paste (Ctrl+V) to replace the text does not replace, but append.

Steps to Reproduce:
1. Navigate to Options / Advanced Options/ Open Expert Configuration
2. Search for a numeric setting such as TotalCacheSize
3. Edit the entry, select the value and press Ctrl+C to copy
4. Now open a calculator and calculate value * 2
5. Select the calculated value from calculator
6. Make sure the text is still selected in LO setting box
7. Select the calculated value from calculator and paste into LO setting box


Actual Results:
The value is appended to the original value which causes text length exceeded message

Expected Results:
If the value in the text box was selected, the value should be overwritten when you paste


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 BogdanB 2018-10-04 16:17:14 UTC
Confirm it, the value from Configuration expert it is not selected anymore, it is just a cursor after the value, so when someone wants to paste a new value, it is not replacing but it is pasteing after the initial value.
Comment 2 BogdanB 2018-10-04 16:20:07 UTC
Created attachment 145391 [details]
video showing the bug

I made a video showing the bug

Versiune: 6.0.6.2
Identificator construire: 1:6.0.6-0ubuntu0.18.04.1
Fire CPU: 4; OS: Linux 4.15; Redare UI: implicit; VCL: gtk3; 
Setări regionale: ro-RO (ro_RO.UTF-8); Calc: group threaded
Comment 3 BogdanB 2018-10-04 16:23:50 UTC
Created attachment 145392 [details]
the good video

the good version of video, the first one was bad recorded...
Comment 4 Xisco Faulí 2018-10-16 17:11:43 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 49c87270f7176312806d1759967c247a312f0acf
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 5 Xisco Faulí 2018-10-16 17:13:01 UTC
@BogdanB, can you reproduce it in master ?
Comment 6 BogdanB 2018-10-16 17:28:37 UTC
(In reply to Xisco Faulí from comment #5)
> @BogdanB, can you reproduce it in master ?

No, it is solved in 
Version: 6.2.0.0.alpha0+
Build ID: 144da6d5079bcd435e6637cb5cf95305f3ec1306
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-10-12_02:13:01
Locale: en-US (ro_RO.UTF-8); Calc: threaded
Comment 7 Xisco Faulí 2018-10-16 17:30:23 UTC
Also fixed in

Versió: 6.1.3.1
ID de la construcció: 1:6.1.3~rc1-0ubuntu0.16.04.1
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded

Closing as RESOLVED WORKSFORME