Download it now!
Bug 120344 - FILEOPEN DOCX Numbering font setting not imported when using direct formatting
Summary: FILEOPEN DOCX Numbering font setting not imported when using direct formatting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Szabolcs Toth
URL:
Whiteboard: target:6.5.0
Keywords: filter:docx
: 97264 (view as bug list)
Depends on:
Blocks: DOCX-Lists-Direct-Formatting
  Show dependency treegraph
 
Reported: 2018-10-05 14:03 UTC by Gabor Kelemen
Modified: 2020-05-04 06:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple file with custom numbering font setting from LO (14.30 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-05 14:03 UTC, Gabor Kelemen
Details
a screenshot showcasing the issue (46.27 KB, image/png)
2018-10-05 14:03 UTC, Gabor Kelemen
Details
How it looks in LibreOffice 6.5 master (84.36 KB, image/png)
2020-01-17 09:54 UTC, Xisco Faulí
Details
How it looks when I open it in 6.5 (58.73 KB, image/png)
2020-01-17 10:22 UTC, Szabolcs Toth
Details
fixed font setting of numbering (9.49 KB, image/png)
2020-01-22 10:41 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-10-05 14:03:04 UTC
Created attachment 145413 [details]
Simple file with custom numbering font setting from LO

The font setting for numbering is saved, but not displayed when opening DOCX file with directly formatted numberings.

Steps to reproduce:
    1. Create a new document in LibreOffice Writer, and add a few paragraphs of random text.
    2. Select the text, and turn on numbering.
    3. Click on the numbering/lettering and change the font from the default to something else.
    4. Save the document as DOCX and reload it.
    5. Optional: open the same file in Microsoft Word (if available).

Actual results:
The font setting of the numbering resets to default in LibreOffice Writer. The setting is retained when the same file is opened in Microsoft Word.

Expected results:
LibreOffice Writer should import custom font settings for numberings when opening a DOCX file.

LibreOffice details:
Version: 6.2.0.0.alpha0+
Build ID: 75a48e37b260c145297261d0e0ab5720894404f1
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: hu-HU (hu_HU); Calc: CL
Comment 1 Gabor Kelemen 2018-10-05 14:03:50 UTC
Created attachment 145414 [details]
a screenshot showcasing the issue

@Laszlo, you might want to guide Balazs on this one
Comment 2 Xisco Faulí 2018-11-12 13:15:56 UTC
Reproduced in

Version: 6.2.0.0.alpha1+
Build ID: 3a99ae072ac170ebed8d1f5bf65913d3412fab67
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 3 QA Administrators 2019-11-13 03:33:30 UTC Comment hidden (obsolete)
Comment 4 Commit Notification 2020-01-10 13:26:36 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f8c12eca80b1faa65f130dfc64c303dcf88a3ac9

tdf#120344 DOCX: fix font style of numbering

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2020-01-17 09:54:31 UTC
Created attachment 157209 [details]
How it looks in LibreOffice 6.5 master
Comment 6 Xisco Faulí 2020-01-17 09:55:56 UTC
Hi Szabolcs, Gabor,
Could you please clarify what the commit fixes ?
I can still reproduce the issue ( see screenshot ) in

Version: 6.5.0.0.alpha0+
Build ID: cc36c115004cb75037b0e4fdadff09035f765cd5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

changing it to REOPENED for the time being
Comment 7 Szabolcs Toth 2020-01-17 10:22:27 UTC
Created attachment 157212 [details]
How it looks when I open it in 6.5

This is how it looks on my PC.
Comment 8 Xisco Faulí 2020-01-17 10:28:23 UTC
Hi Szabolcs,
is it your local build where you normally hack? Do you see the same behaviour in a daily build? Just asking in case you forgot to submit a change you only have. That would explain why I can reproduce it and you can't
Comment 9 Szabolcs Toth 2020-01-17 10:43:17 UTC
Hi Xisco,
I'm in master, with a git pull from Monday, freshly built after a hard reset.
Comment 10 László Németh 2020-01-17 11:48:48 UTC
@Xisco: on a 2020-01-06 parent, the merged commit fixes the issue. We will going to check it with a fresh master, too.
Comment 11 Aron Budea 2020-01-17 13:54:50 UTC
It seems to be a case of missing font, the numbering uses Lucida Handwriting font, not present in Linux by default.
Comment 12 László Németh 2020-01-22 10:41:54 UTC
Created attachment 157316 [details]
fixed font setting of numbering
Comment 13 László Németh 2020-01-22 10:45:37 UTC
@Xisco: I've checked with a newer master, and the bug is really fixed, see the attached screenshot: moving the text cursor to the numbering, the fixed font setting is visible on the toolbar on Linux, too. Sorry for the missing explanation, and thanks for your verification!
Comment 14 Xisco Faulí 2020-01-22 11:38:56 UTC
Hi all,
Sorry for my delay here.
As Aron mentioned, I didn't have the font installed.
I do verified the issues is fixed in

Version: 6.5.0.0.alpha0+
Build ID: b92293b3943423324064a8513c2e114d18817179
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Sorry for the inconveniences caused
Comment 15 NISZ LibreOffice Team 2020-05-04 06:57:40 UTC
*** Bug 97264 has been marked as a duplicate of this bug. ***