Bug Hunting Session
Bug 120373 - Hyperlink removal functionality "hidden" by default
Summary: Hyperlink removal functionality "hidden" by default
Status: RESOLVED DUPLICATE of bug 62561
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 62561
Blocks: Hyperlink-Calc 87459
  Show dependency treegraph
 
Reported: 2018-10-07 08:24 UTC by Eyal Rozenberg
Modified: 2018-10-13 10:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
writer hyperlink context menu (25.51 KB, image/jpeg)
2018-10-07 15:32 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2018-10-07 08:24:43 UTC
Suppose I have a cell with a hyperlink. How do I remove it?

* Right-click context menu -> No removal option
* Hover -> No removal option
* Edit Menu -> Nothing to do with links
* Format Menu -> Nothing to do with links
* Any other menus -> Again, nothing to do with links

It seems like my only option, with the default menu and toolbars, is "Insert Hyperlink" on the main toolbar, which opens the edit dialog - but even there I don't see a Remove Link options.

What's going on here?

Even if I've missed something, I claim that the right-click menu, _and_ the Edit (or another) menu, should both by default have some entry or button for removing the link. Also, the link edit dialog should allow removal.
Comment 1 Oliver Brinzing 2018-10-07 09:13:44 UTC
(In reply to Eyal Rozenberg from comment #0)
> Suppose I have a cell with a hyperlink. How do I remove it?

have you tried to press delete key ?

there is an old issue dealing with hyperlinks:
CONTEXT MENU: Addition of 'Edit Hyperlink' entry in cell edit mode
https://bugs.documentfoundation.org/show_bug.cgi?id=87459
Comment 2 Eyal Rozenberg 2018-10-07 11:03:44 UTC
(In reply to Oliver Brinzing from comment #1)
> have you tried to press delete key ?

I want to delete the link, not the text (nor the entire cell contents)...
Comment 3 Eyal Rozenberg 2018-10-07 11:11:30 UTC
(In reply to Oliver Brinzing from comment #1)
> there is an old issue dealing with hyperlinks:
> CONTEXT MENU: Addition of 'Edit Hyperlink' entry in cell edit mode
> https://bugs.documentfoundation.org/show_bug.cgi?id=87459

But even that dialog doesn't seem to have a Remove button. Plus, it's not nearly enough.

I should also add that, when I add "Edit Hyperlink" and "Remove Hyperlink" to the Menus using Customize, and position my cursor over a cell with a hyperlink in it - they're grayed out.
Comment 4 Oliver Brinzing 2018-10-07 15:32:23 UTC
Created attachment 145447 [details]
writer hyperlink context menu

(In reply to Eyal Rozenberg from comment #2)
> I want to delete the link, not the text (nor the entire cell contents)...

LO will recognize a link if Menu "Tools/AutoCorrect Options.../Options"
"[X] URL Recognition" is enabled.
but disabling this feature will not convert existing links into text.

if I understand you correctly you want to add the same context menu
entries to calc as we have in writer?
Comment 5 Eyal Rozenberg 2018-10-07 20:23:13 UTC
(In reply to Oliver Brinzing from comment #4)
> LO will recognize a link if Menu "Tools/AutoCorrect Options.../Options"
> "[X] URL Recognition" is enabled.

But:
1. I shouldn't have to know that; that option is for auto-converting text into links.
2. The URL is already recognized - it's right there :-(


> if I understand you correctly you want to add the same context menu
> entries to calc as we have in writer?

That would be part of the solution. A full solution IMO would include:

* Context menu entries for editing and removing a hyperlink
* Remove link button in the edit dialog
* Menu items for hyperlinks - either a single menu item which changes when you're on a link (e.g. to edit instead of insert), or multiple entries which include removing hyperlinks for the selection
* A change of semantics for the hyperlink toolbar button. And either it changes graphic to indicate "Edit" when on a hyperlink, or it always indicate "Add/Edit" somehow. Another option is to make it into a sort of a menu-button.
Comment 6 Timur 2018-10-10 15:27:16 UTC

*** This bug has been marked as a duplicate of bug 62561 ***
Comment 7 Eyal Rozenberg 2018-10-10 16:15:28 UTC
@Timur: I explained why this bug is not a duplicate of that one. This is not just about the context menu, which is just a part of the issue. The relation is more of a dependence.
Comment 8 Heiko Tietze 2018-10-12 09:39:07 UTC
(In reply to Eyal Rozenberg from comment #7)
> @Timur: I explained why this bug is not a duplicate of that one. This is not
> just about the context menu, which is just a part of the issue. The relation
> is more of a dependence.

Searching for Hyperlink in Calc returns 45 results. For example 112994 and 87459 are similar to your report. We should combine the issues as best as possible according use cases. And bug 62561 is good enough to cover not only the context menu but also the main menu.

Basically the issue is that the UNO commands EditHyperlink and RemoveHyperlink are not defined for Calc. Maybe the code is missing at all.

*** This bug has been marked as a duplicate of bug 62561 ***
Comment 9 Eyal Rozenberg 2018-10-12 19:05:08 UTC
(In reply to Heiko Tietze from comment #8)

Well, I weakly disagree, but not enough to argue about it, so ok.
Comment 10 Heiko Tietze 2018-10-13 10:09:50 UTC
(In reply to Eyal Rozenberg from comment #9)
> (In reply to Heiko Tietze from comment #8)
> 
> Well, I weakly disagree, but not enough to argue about it, so ok.

Fully understand that it hurts when an elaborated bug report with some useful comments is resolved as just a duplicate. Sorry for that, hope we can fix the issue to your satisfaction soon.