Bug 120409 - Digital Signatures -> Select certificate got missing on 6.2 alpha
Summary: Digital Signatures -> Select certificate got missing on 6.2 alpha
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2018-10-08 11:56 UTC by Juan Jose Pablos
Modified: 2018-10-23 01:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Jose Pablos 2018-10-08 11:56:16 UTC
Description:
I am testing the use of smart card with the Spanish Royal Mint (FNMT) certificate to sign Documents.
I am able to sign just fine when the certificate is installed on the operation system (Windows 7 64Bits). But when I export to a smart card. That functionality stop working. I have download libo-master64~2018-10-07_23.36.50_LibreOfficeDev_6.2.0.0.alpha0_Win_x64.msi to see if a new version gets better.
But for my surprise "Select Certificate" got empty with the new version.




Steps to Reproduce:
1. On Writer. File > Digital Signatures > Digital Signatures...
2. Click on Sign Document...
3. The Select Certificate should show a certificate 

Actual Results:
The list of certificates is emptied

Expected Results:
As it was on libreoffice 6.1.2. You could select the certificate and Click Sign


Reproducible: Always


User Profile Reset: No



Additional Info:
I never have been able to sign with the Spanish Royal Mint SmartCard. But this seem like a regression to me.
I was expecting to see the results of these changes:
https://vmiklos.hu/blog/xmlsec-cng-ecsa.html
Comment 1 Juan Jose Pablos 2018-10-08 12:05:00 UTC
I forgot to Add the Hardware information:

USB Smart Card Reader: C3PO LTC31 v2 (00626183)

Smart Card: Ceres ST v3
3B 7F 38 00 00 00 6A 43 45 52 45 53 02 2C 34 03 80 03 90 00
Comment 2 Julien Nabet 2018-10-08 12:12:35 UTC
Miklos: since it concerns certificate, thought you might be interested in this one.
Comment 3 Juan Jose Pablos 2018-10-23 00:38:11 UTC
I just Download 	-	-
libo-master64~2018-10-22_01.47.50_LibreOfficeDev_6.2.0.0.alpha1_Win_x64.msi
and I can manage to sign just fine.