Bug 120423 - LibreOffice Base -> can't insert special character in a form
Summary: LibreOffice Base -> can't insert special character in a form
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All All
: high normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Database-Forms
  Show dependency treegraph
 
Reported: 2018-10-08 14:39 UTC by Vera Blagoveschenskaya
Modified: 2019-05-17 11:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-10-08 14:39:06 UTC
Description:
LibreOffice Base -> can't insert special character in a form

Steps to Reproduce:
1. LibreOffice Base -> Create a database
2. Create a form in Design view
3. Insert -> Special character, select some character

Actual Results:
Character is not inserted 

Expected Results:
Character is inserted


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Drew Jensen 2018-10-08 15:30:34 UTC
Confirmed using Ubuntu 18.04 and LibreOffice 6.1.2 and 6.2 Alpha, it is also a problem in 6.0. 

It appears that a character is inserted, as a line of text with a special character inserted in the center gets longer by one character space but the character is not displayed. 

In 5.4 there is also an issue where the character does not immediately display but if you close the form and open it then it does - that does not work for 6.0 and higher however.
Comment 2 Alex Thurgood 2018-10-08 15:52:26 UTC
@Drew : Data loss ?
Comment 3 Drew Jensen 2018-10-08 16:50:25 UTC
(In reply to Alex Thurgood from comment #2)
> @Drew : Data loss ?

No - unless I misunderstood what was being reported here. 

Currently the only time the Special Character menu item is available is when you are editing the form proper (not entering/editing data in a form control). In this case then the special character is to be part of the static text on the form background.

For data entry, even in text fields, the menu item for special characters is not active. The only way to add one is to paste it/them from the system clipboard. 

To be honest a RFE for the special characters dialog menu item to be active when editing character data in a control would make sense to me; but I took it only to be about the problem adding one to the static text on the form.

I wouldn't set this importance to high or major IMO.
Comment 4 Drew Jensen 2018-10-08 17:29:41 UTC
(In reply to Alex Thurgood from comment #2)
> @Drew : Data loss ?

My first answer to you was not correct - as you likely know but others may not.

In a data control the context menu for Special Characters is enabled and that does work in all the versions. It is only the top level menu 'Insert->Special Character' which is not enabled.
Comment 5 Alex Thurgood 2018-10-09 07:58:33 UTC
@Drew - thanks !

In my attempts to confirm, I did the same as you, and tried inserting a special character into the Form document in design mode from the main menu. As you say, this worked up to 5.4.x and no longer works in 6.0.x releases and current 6.1.x.

Still a bug, still a regression, but not as catastrophic as one might think, therefore reducing severity.
Comment 6 raal 2019-05-11 17:01:08 UTC
This seems to have begun at the below commit.
Adding Cc: to Akshay Deep ; Could you possibly take a look at this one?
Thanks

3fdb504b62b2682a5e6dcec0fb3b0b3a974f5671 is the first bad commit
commit 3fdb504b62b2682a5e6dcec0fb3b0b3a974f5671
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Jun 20 19:22:51 2017 +0200

    source sha:710a39414569995bd5a8631a948c939dc73bcef9

author	Akshay Deep <akshaydeepiitr@gmail.com>	2017-05-11 13:27:38 +0530
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-06-19 14:36:32 +0200
commit	710a39414569995bd5a8631a948c939dc73bcef9 (patch)
tree	e3da87fd9012713605004e8bd20ca2b98df45ac5
parent	cacb75aa0bea36d4e5fc083a75a8b376133d3d65 (diff)
GSoC: Glyph View and Recent Characters Control in Special Characters dialog
Comment 7 Xisco Faulí 2019-05-13 14:48:38 UTC
Hi Caolán, since you fixed bug 113805 and bug 116138 introduced by 710a39414569995bd5a8631a948c939dc73bcef9 I thought you might be interested in this issue...
Comment 8 Commit Notification 2019-05-14 15:13:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/430b3f4db745dfe08b989745e340e0503dd0ac34%5E%21

Resolves: tdf#120423 dispatch against the correct Frame

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2019-05-14 15:24:40 UTC
fixed in master, backport to 6-2 in gerrit
Comment 10 Commit Notification 2019-05-15 17:05:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cdaa535937a645345b91c90fbebae344c811e741%5E%21

Resolves: tdf#120423 dispatch against the correct Frame

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-05-17 11:38:38 UTC
Verified in

Version: 6.3.0.0.alpha1+
Build ID: 4c2034b808fed4f9dfd715d8a4813e788a7e97a4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!