Bug 120423 - LibreOffice Base -> can't insert special character in a form
Summary: LibreOffice Base -> can't insert special character in a form
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Database-Forms
  Show dependency treegraph
 
Reported: 2018-10-08 14:39 UTC by Vera Blagoveschenskaya
Modified: 2018-10-24 10:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-10-08 14:39:06 UTC
Description:
LibreOffice Base -> can't insert special character in a form

Steps to Reproduce:
1. LibreOffice Base -> Create a database
2. Create a form in Design view
3. Insert -> Special character, select some character

Actual Results:
Character is not inserted 

Expected Results:
Character is inserted


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Drew Jensen 2018-10-08 15:30:34 UTC
Confirmed using Ubuntu 18.04 and LibreOffice 6.1.2 and 6.2 Alpha, it is also a problem in 6.0. 

It appears that a character is inserted, as a line of text with a special character inserted in the center gets longer by one character space but the character is not displayed. 

In 5.4 there is also an issue where the character does not immediately display but if you close the form and open it then it does - that does not work for 6.0 and higher however.
Comment 2 Alex Thurgood 2018-10-08 15:52:26 UTC
@Drew : Data loss ?
Comment 3 Drew Jensen 2018-10-08 16:50:25 UTC
(In reply to Alex Thurgood from comment #2)
> @Drew : Data loss ?

No - unless I misunderstood what was being reported here. 

Currently the only time the Special Character menu item is available is when you are editing the form proper (not entering/editing data in a form control). In this case then the special character is to be part of the static text on the form background.

For data entry, even in text fields, the menu item for special characters is not active. The only way to add one is to paste it/them from the system clipboard. 

To be honest a RFE for the special characters dialog menu item to be active when editing character data in a control would make sense to me; but I took it only to be about the problem adding one to the static text on the form.

I wouldn't set this importance to high or major IMO.
Comment 4 Drew Jensen 2018-10-08 17:29:41 UTC
(In reply to Alex Thurgood from comment #2)
> @Drew : Data loss ?

My first answer to you was not correct - as you likely know but others may not.

In a data control the context menu for Special Characters is enabled and that does work in all the versions. It is only the top level menu 'Insert->Special Character' which is not enabled.
Comment 5 Alex Thurgood 2018-10-09 07:58:33 UTC
@Drew - thanks !

In my attempts to confirm, I did the same as you, and tried inserting a special character into the Form document in design mode from the main menu. As you say, this worked up to 5.4.x and no longer works in 6.0.x releases and current 6.1.x.

Still a bug, still a regression, but not as catastrophic as one might think, therefore reducing severity.