Bug Hunting Session
Bug 120432 - Date, Time and Formulas Can be Inserted in Read-only Spreadsheets
Summary: Date, Time and Formulas Can be Inserted in Read-only Spreadsheets
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.2.0 target:6.1.4
Keywords:
Depends on:
Blocks: Read-Only
  Show dependency treegraph
 
Reported: 2018-10-08 19:25 UTC by Harald Koester
Modified: 2019-01-17 10:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-10-08 19:25:33 UTC
In order to reproduce the bug:

[1] Open new spreadsheet.
[2] Insert some text in a cell.
[3] Save but don't close spreadsheet.
[4] Change to read-only mode: Edit > Edit Mode.
[5] Insert Date: Insert > Date. A number is inserted into cell and a message is displayed: “Document opened in read-only mode”. Expected: “Date” should be greyed and inserting of a date should not be possible. Then a message is no longer necessary.

If you insert the time, it happens the same. Also a formula can be inserted similarly in a read-only spreadsheet (Insert > Object > Formula...).
Comment 1 BogdanB 2018-10-09 05:40:46 UTC
confirm on
Version: 6.1.2.1 (x64)
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ro-RO (ro_RO); Calc: group threaded
Comment 2 Xavier Van Wijmeersch 2018-10-09 16:39:01 UTC
i have a date with

Version: 6.2.0.0.alpha0+
Build ID: 9ed8a1bfffd608b31badeae5341ebf0b48501419
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: threaded

but with  i confirm  the problem

Version: 6.1.3.0.0+
Build ID: c523d9556a354e1afac3203b6f1c8b75a2f7d2f0
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 3 Oliver Brinzing 2018-10-10 16:32:33 UTC
this seems to be similar:
https://bugs.documentfoundation.org/show_bug.cgi?id=107240
EDITING Insert > Date | Time inserts some content into protected cells
Comment 4 Xisco Faulí 2018-10-18 19:13:08 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/61953/
Comment 5 Commit Notification 2018-11-15 21:34:52 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/525ed5d1fcb89412f0b80be0b1e35410b048c337%5E%21

tdf#107240 tdf#120432 Disable time/date entries in read-only/protected mode

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2018-11-15 23:50:54 UTC
Closing as RESOLVED FIXED
Comment 7 Commit Notification 2018-11-16 12:44:06 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/da6c0638507aec8c9e8be2b8f63140136f1bff1d%5E%21

tdf#107240 tdf#120432 Disable time/date entries in read-only/protected mode

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Harald Koester 2019-01-17 10:41:25 UTC
Verified with version 6.1.4. Works as expected now --> Bug closed.