Bug 120448 - [Regression] Slowness with a simple document
Summary: [Regression] Slowness with a simple document
Status: RESOLVED DUPLICATE of bug 119340
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-09 10:17 UTC by Olivier R.
Modified: 2018-10-10 12:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
2 pages document, very slow to scroll or modify (24.39 KB, application/vnd.oasis.opendocument.text)
2018-10-09 10:18 UTC, Olivier R.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier R. 2018-10-09 10:17:31 UTC
Description:
LibreOffice 6.1 has become very slow, especially with some document. See the one provided with the bug report.

This document is 2 pages only.

It’s very slow to open.
When scrolling top to bottom and especially bottom to top, it’s very slow.
Almost every operation is slow especially if you modify the structure of the document. It seems that what slows LO is the way it displays pages.
After saving the document, LibreOffice freezes.

It’s almost unusable.

This document often uses characters styles, which seems to be one of the cause of the slowness. I have bigger documents which can be modified better.

Steps to Reproduce:
Just try to make major modifications to the document, and see how slow it is.

Actual Results:
It’s so much slow it’s barely usable.

Expected Results:
Better reaction. No freezes.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Olivier R. 2018-10-09 10:18:50 UTC
Created attachment 145513 [details]
2 pages document, very slow to scroll or modify
Comment 2 Jean-Baptiste Faure 2018-10-09 12:15:25 UTC
Not reproducible for me with LO 6.1.2 from Ubuntu PPA and with LO 6.1.3.0.0+ built at home under Ubuntu 18.04 x86-64.

Which version are you using? The field version says 6.0.0.3 and your description says 6.1.

Best regards. JBF
Comment 3 Olivier R. 2018-10-09 12:26:57 UTC
I set the wrong version. I tried with LO 6.1.0 and LO 6.1.2 on Windows 10.
Comment 4 Xisco Faulí 2018-10-10 11:19:44 UTC
I can reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 425af6845ebe066c950b0b63f50563e067485f3e
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); Calc: threaded

but not in

Versión: 6.1.2.1
Id. de compilación: 65905a128db06ba48db947242809d14d3f9a93fe
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded
Comment 5 Xisco Faulí 2018-10-10 11:27:16 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=2ee177e58a57420eaa18b9d39ade4c28907bc0c8

Closing as RESOLVED DUPLICATED of bug 119756

*** This bug has been marked as a duplicate of bug 119756 ***
Comment 6 Olivier R. 2018-10-10 11:59:19 UTC
I’m using:
Version: 6.1.2.1 (x64)
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
Threads CPU : 8; OS : Windows 10.0; UI Render : GL; 
Locale : fr-FR (fr_FR); Calc: CL

And the slowness is still there, even when the sidebar is closed.

It doesn’t seem to be a duplicate.
Comment 7 Xisco Faulí 2018-10-10 12:08:02 UTC
Sorry, I've investigating it a bit further and this got fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-6-1&id=fbc3818a70bad11f2b28d005d97c3491a41f711e, so it will be fixed in LibreOffice 6.1.3

*** This bug has been marked as a duplicate of bug 119340 ***