Bug 120476 - UI : cell formatting dialog too big and not resizable
Summary: UI : cell formatting dialog too big and not resizable
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Cell-Format-Dialog
  Show dependency treegraph
 
Reported: 2018-10-10 07:26 UTC by Jean-Baptiste Faure
Modified: 2018-10-11 21:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
dialog too high (830.29 KB, image/png)
2018-10-10 07:26 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2018-10-10 07:26:01 UTC
Description:
In current master, the cell formatting dialog is not resizable and too high so that the buttons at the bottom are not visible.


Steps to Reproduce:
1.open Calc
2.right click on a cell and choose Format Cells
3.

Actual Results:
see attached screencopy

Expected Results:
the dialog window should be resizable


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 87e3539d69626780c6d7531b725dd0d64c69e6d8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale: fr-FR (fr_FR.UTF-8); Calc: threaded
Comment 1 Jean-Baptiste Faure 2018-10-10 07:26:41 UTC
Created attachment 145549 [details]
dialog too high
Comment 2 Xavier Van Wijmeersch 2018-10-10 21:10:36 UTC
confirm with

Version: 6.2.0.0.alpha0+
Build ID: 095caf5c7501e982b8e10b4619e47885a22d07c6
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: threaded
Comment 3 Jean-Baptiste Faure 2018-10-10 21:34:11 UTC
This issue occurs if Asian and Complex text layout are unchecked in Tools > Options > Language Settings > Languages

Same issue with a clean new user profile.

Best regards. JBF
Comment 4 Jean-Baptiste Faure 2018-10-10 21:38:12 UTC
Hi Caolan,

I guess you may interested in this bug report.

Best regards. JBF
Comment 5 Xisco Faulí 2018-10-11 09:58:44 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 59ed21b1720db5fd0326e1b723483b288725e662
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

even if asian and complex text layouts are unchecked

Gtk version 3.18.9.

@Jean-Baptiste, which version of GTK3 are you using?
Comment 6 Jean-Baptiste Faure 2018-10-11 10:18:11 UTC
(In reply to Xisco Faulí from comment #5)
> I can't reproduce it in
> 
> Version: 6.2.0.0.alpha0+
> Build ID: 59ed21b1720db5fd0326e1b723483b288725e662
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
> 
> even if asian and complex text layouts are unchecked
> 
> Gtk version 3.18.9.
> 
> @Jean-Baptiste, which version of GTK3 are you using?

I am using Ubuntu 18.04 and Synaptic says that the package libgtk-3 is in version 3.22.30

Best regards. JBF
Comment 7 Commit Notification 2018-10-11 18:46:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=14337672d2793fec5ec1cebcced33d04ecf4d0c6

Resolves: tdf#120476 need to be resizable if number of tabs is variable

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2018-10-11 18:46:48 UTC
should work again now
Comment 9 Jean-Baptiste Faure 2018-10-11 21:22:11 UTC
Verified fixed in
Version: 6.2.0.0.alpha0+
Build ID: 14337672d2793fec5ec1cebcced33d04ecf4d0c6
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

Thank you very much.

Best regards. JBF