Download it now!
Bug 120478 - JDBC driver test could not be loaded - wrong icon
Summary: JDBC driver test could not be loaded - wrong icon
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.2.0 target:6.1.3
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-10 10:03 UTC by grofaty
Modified: 2018-10-19 13:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
error_message_icon.png (25.21 KB, image/png)
2018-10-10 10:03 UTC, grofaty
Details
JDBC Driver load failure error message dialog on MacOS (13.21 KB, image/png)
2018-10-10 11:40 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2018-10-10 10:03:18 UTC
Created attachment 145556 [details]
error_message_icon.png

Hi,
1. I have opened LibreOffice Base and Database Wizard opens.
2. Select database: check "Connect to an existing databse" and select "JDBC".
3. Click on Next button.
4. In "JDBC driver class" type in dummy and click on Test Class button.
5. Message is displayed: "The JDBC driver could not be loaded."
It is obvious this is a fatal problem, but icon is "blue i". Icon should be "red x". "Blue i" icon should be reserved for success, not failure. See attached image. I hate to read messages, the icon should be enough to recognize success or failure.

P.S. Also error is pretty cryptic. I have spend quite some time to figure it out what is wrong.
1. Java Runtime Environment must be installed.
2. JDBC driver must be present.
3. In LibreOffice Tools | Options | LibreOffice | Advanced | Class Path button | driver path has to be set.
4. Now repeating the steps above and everything is fine.
May I additionally suggest to provide more informed message or add some Help button to link to some good documentation.
Comment 1 Alex Thurgood 2018-10-10 11:37:34 UTC
This works for me on MacOS with 

Version: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
Threads CPU : 4; OS : Mac OS X 10.13.6; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded


so Windows specific ?
Comment 2 Alex Thurgood 2018-10-10 11:40:03 UTC
Created attachment 145564 [details]
JDBC Driver load failure error message dialog on MacOS

See the dialog displayed on MacOS for comparison
Comment 3 Julien Nabet 2018-10-10 21:02:54 UTC
On pc Debian x86-64 with master sources updated today + gen rendering, I could reproduce this.
Comment 4 Julien Nabet 2018-10-10 21:16:14 UTC
I've submitted a patch on gerrit,
see https://gerrit.libreoffice.org/#/c/61637/
(master only for the moment).
Comment 5 Commit Notification 2018-10-11 07:11:09 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b44c2c525a663dbee3d88785ddcd0d5781002da

tdf#120478: fix wrong icon when JDBC driver test fails

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Julien Nabet 2018-10-11 07:22:35 UTC
Backport for 6.1 branch waiting for review here:
https://gerrit.libreoffice.org/#/c/61643/
Comment 7 Commit Notification 2018-10-11 08:34:44 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4de54f8c6795c0b16f3fd3fbd1820249fd318a88&h=libreoffice-6-1

tdf#120478: fix wrong icon when JDBC driver test fails

It will be available in 6.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 grofaty 2018-10-15 10:30:53 UTC
Tested on latest 6.1-dev version and I can confirm this problem is fixed.
Thank you.


=== Version tested ===
Version: 6.1.4.0.0+
Build ID: 2e27d2e3397efc1fcc4478bce286c5ec64c118e9
CPU threads: 3; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:libreoffice-6-1, Time: 2018-10-15_07:59:30
Locale: sl-SI (sl_SI); Calc: group threaded
Comment 9 Commit Notification 2018-10-19 08:37:07 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c229a77ac5cf935f6f189a644811a253c1bc36de&h=libreoffice-6-1-3

tdf#120478: fix wrong icon when JDBC driver test fails

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Julien Nabet 2018-10-19 09:36:54 UTC
Simplify targets