Bug Hunting Session
Bug 120493 - Add new feature: Writer sheet for Calc or Calc subdocument for Writer
Summary: Add new feature: Writer sheet for Calc or Calc subdocument for Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-10 19:13 UTC by ejj_samyn_stp
Modified: 2018-11-29 13:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ejj_samyn_stp 2018-10-10 19:13:36 UTC
Would be nice to have a kind of merge between calc and write so that you could have sheets with a calc or write type in a single document.

This would allow to build document with both textual info and spreadsheet data 
example : a report with some "write" sheets to give textual info (introduction, explanations, ...) and sheets for data, graph, ...

Hope this is quite clear.

Regards
Comment 1 Jean-Baptiste Faure 2018-10-11 05:46:12 UTC
Did you try to embed a Calc file in a text document? 

Status set to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 2 ejj_samyn_stp 2018-11-24 20:02:02 UTC
(In reply to Jean-Baptiste Faure from comment #1)
> Did you try to embed a Calc file in a text document? 
> 
> Status set to NEEDINFO, please set it back to UNCONFIRMED once requested
> informations are provided.
> 
> Best regards. JBF

Yes, but it would be much easier to work with a single file with both properties. To embed calc in write is nice when you just want a table or a graph, but not very practical when you want a real spreadsheet tool with some textual sheet to add formated text to complete your doc (for example if you want to add a textual introduction, a user guide for your spreadsheet with title levels, paragraphs,.., a contextual description, ...)

Hope this is clearer
Comment 3 Timur 2018-11-28 16:20:14 UTC
I guess there are 2 options: add Writer sheet for Calc or add Calc subdocument for Writer master.

I'm not in favor of this idea because, while explanation makes sense, it is achieved with 2 different documents:
1. textual info.odt
2.  data and graph.ods
Comment 4 Heiko Tietze 2018-11-29 13:22:32 UTC
The OLE embedding of Spreadsheets in Writer and documents in Calc works perfectly for me. Don't see the need for further integration a la master document and doubt it's possible from the format perspective. Keep in mind that we are bound to the specification.