Bug 120508 - FILEOPEN DOCX Image is scaled instead of cropped in a particular DOCX document
Summary: FILEOPEN DOCX Image is scaled instead of cropped in a particular DOCX document
Status: RESOLVED DUPLICATE of bug 118140
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-10-11 12:16 UTC by NISZ LibreOffice Team
Modified: 2019-10-22 10:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The DOCX document saved with MS Word. (71.03 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-11 12:18 UTC, NISZ LibreOffice Team
Details
The original document exported as PDF with MS Word. (66.31 KB, application/pdf)
2018-10-11 12:19 UTC, NISZ LibreOffice Team
Details
screenshot showcasing the issue. (642.09 KB, image/png)
2018-10-11 12:19 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-10-11 12:16:27 UTC
Description:
This DOCX document has an image which is scaled and cropped in Microsoft Word. In LibreOffice, the image is scaled with the factor of the original scale and crop and there is no cropping at all.

Steps to Reproduce:
1.Open the attached DOCX document both in Microsoft Word and LibreOffice Writer and compare the results (alternatively, you can use the attached MS Word exported PDF as reference).
2.
3.

Actual Results:
The image is scaled with the factor of the original scale and crop values, but not cropped.

Expected Results:
The image should be scaled and cropped as in MS Word.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-10-11 12:18:41 UTC
Created attachment 145593 [details]
The DOCX document saved with MS Word.
Comment 2 NISZ LibreOffice Team 2018-10-11 12:19:05 UTC
Created attachment 145594 [details]
The original document exported as PDF with MS Word.
Comment 3 NISZ LibreOffice Team 2018-10-11 12:19:27 UTC
Created attachment 145595 [details]
screenshot showcasing the issue.
Comment 4 Xisco Faulí 2018-10-11 13:42:34 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=8484e52675052848d2d3ffe07378ce2ad29fd288 which is the same as in bug 118140
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 118140 ***