Bug 120520 - UI: Paragraph settings are unavailable when an image is selected
Summary: UI: Paragraph settings are unavailable when an image is selected
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-11 14:07 UTC by NISZ LibreOffice Team
Modified: 2018-11-15 09:13 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A screenshot showcasing the issue. (71.92 KB, image/png)
2018-10-11 14:08 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-10-11 14:07:41 UTC
Description:
This is a minor UI enhancement request.

When an image is selected, LibreOffice Writer hides the paragraph setting options, including paragraph alignment settings. This might be understandable from a technical point, but might be confusing for many when an image is anchored as character and the user wants to align the image to the center.

Making the paragraph property options available when an image is selected is not that different from the case, when only a part of the text is selected: paragraph settings still apply to the whole paragraph.

As the paragraph-related icons on the toolbar are significantly different from the image-related icons, I don't think that this would cause any confusion for the users, it would be still easy to determine, which buttons apply to the image and which buttons to the paragraph, so from a usability standpoint there is no need to hide the icons in the first place.

There might be technical reasons why paragraph settings are unavailable when an image is selected that I am not aware of. If it would take a significant work to change this behavior then you can close my bug with won't fix, as I don't think a minor usability enhancement like this would warrant too much effort.

Steps to Reproduce:
1. Create a new text document in LibreOffice Writer.
2. Insert an image by clicking on Insert > Image.
3. Click with the right button on the image and select Anchor > As character from the popup menu.
4. Try to align the image to the center: there is no obvious way to do it until you deselect (click outside) the image.

Actual Results:
Paragraph setting are unavailable when an image is selected.

Expected Results:
Having paragraph settings available even when an image is selected would make centering “as character” aligned images easier and more intuitive.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-10-11 14:08:10 UTC
Created attachment 145611 [details]
A screenshot showcasing the issue.
Comment 2 Jean-Baptiste Faure 2018-10-14 14:49:12 UTC
For me it's not a bug.

Best regards. JBF
Comment 3 Xisco Faulí 2018-11-14 11:54:35 UTC
I think this is the expected behaviour... Adding the UX Team just in case...
Comment 4 Heiko Tietze 2018-11-15 09:13:56 UTC
The image is placed in a paragraph, when you put the cursor left or right of it you can change the alignment to center.

The ODF spec [1] says "The <draw:image> element has the following child elements: <office:binary-data> 10.4.5, <text:list> 5.3.1 and <text:p> 5.1.3." (the latter is the paragraph). 

In a nutshell: images cannot have alignment properties.

[1] http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.html#__RefHeading__1415852_253892949