Download it now!
Bug 120661 - Deleted inherited tab stops are put back in exported DOCX file
Summary: Deleted inherited tab stops are put back in exported DOCX file
Status: RESOLVED DUPLICATE of bug 63561
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-17 15:50 UTC by Matthew Kogan
Modified: 2018-10-18 09:01 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Test ODT (8.64 KB, text/odt)
2018-10-18 09:01 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Kogan 2018-10-17 15:50:12 UTC
Description:
A document exported to DOCX does not honour the deletion of tab stops that have been inherited from another style.

Steps to Reproduce:
1.Create a style called Style1 with a tab stop at 0.5cm.
2.Create a style called Style2, which inherits from Style1, but has no tab stops.
3.Insert a paragraph with a tab at the beginning, styled with Style1.
4.Insert a paragraph with a tab at the beginning, styled with Style2.
5.Note that the second paragraph does not have a tab at 0.5cm, and uses the application default tab stop (1.25cm for me).
5.Save a copy of the document as Microsoft Word 2007-2013 XML (.docx).
6.Open the docx file in Word or in Writer.

Actual Results:
Both paragraphs have a tab stop at 0.5cm.

Expected Results:
The second paragraph should not have a tab stop at 0.5cm.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Matthew Kogan 2018-10-17 16:24:52 UTC
Sorry, I think this may be a duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=63561.
Comment 2 Timur 2018-10-18 09:01:01 UTC
Even if we reopen in LO docx saved in LO 5.4, both paragraphs have a tab stop at 0.5cm. 
If we open docs saved in LO 6.1, it's OK.

Thank you for properly reporting a bug. Next time please also attach source ODT so that testers may immediately test. 
And thank you for looking for duplicate.

Note: If you are on 5.4 please use last 5.4.7.2.

*** This bug has been marked as a duplicate of bug 63561 ***
Comment 3 Timur 2018-10-18 09:01:59 UTC
Created attachment 145799 [details]
Test ODT