Download it now!
Bug 120669 - When using LTR and RTL texts on mac, the flow is faulty
Summary: When using LTR and RTL texts on mac, the flow is faulty
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-18 05:39 UTC by nisimnaim
Modified: 2018-10-28 06:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
An example document with the steps to reproduce (8.95 KB, application/vnd.oasis.opendocument.text)
2018-10-18 05:40 UTC, nisimnaim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nisimnaim 2018-10-18 05:39:02 UTC
Description:
Creating a document with RTL, and typing text in both Hebrew (RTL language) and English (LTR language), the order of the English parts is coming out wrong.

Steps to Reproduce:
1. Create a new Writer (.odt) document
2. Set the typing method to be RTL
3. Type a few words in Hebrew \ Arabic (both are RTL languages)
4. Type a word in English
5. repeat steps 3 & 4

Actual Results:
The order of the words is not as typed

Expected Results:
The order of the words in the sentence will be as typed


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 nisimnaim 2018-10-18 05:40:38 UTC
Created attachment 145795 [details]
An example document with the steps to reproduce

Copy the text into Microsoft Office Word and see that the order of the words in the sentence is right. But in Writer it is wrong.
Comment 2 Alex Thurgood 2018-10-19 07:23:18 UTC

*** This bug has been marked as a duplicate of bug 56408 ***
Comment 3 Khaled Hosny 2018-10-20 19:54:11 UTC
The paragraph in your document has its direction set to left to right not right to left, though it is right aligned. You need to change that to get the right text order.
Comment 4 nisimnaim 2018-10-21 05:26:37 UTC
I can't seem to find the buttons to change the RTL\LTR directions. Where are they hidden?
Comment 5 Khaled Hosny 2018-10-23 10:01:21 UTC
You may need to enable https://help.libreoffice.org/Common/Languages#CTL
Comment 6 nisimnaim 2018-10-28 06:44:56 UTC
I wasn't able to follow the instruction. Might it be that i am using a different version and the instructions have change?