Download it now!
Bug 120687 - Slow repeated repagination on scroll
Summary: Slow repeated repagination on scroll
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2018-10-18 21:55 UTC by Eyal Rozenberg
Modified: 2019-01-11 18:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Document exhibiting the bug (15.12 KB, application/vnd.oasis.opendocument.text)
2018-10-18 22:28 UTC, Eyal Rozenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2018-10-18 21:55:08 UTC
Description:
In some documents, originally created in MS-Word (but not all of them obviously), LO Writer slows down incredibly as we scroll up and down, and we see this "blue bar" progressing across the page boundaries, suggesting repagination is occurring. But it progresses all the way, resets, then repeats over and over again - for no apparent reason.

Steps to Reproduce:
1. Open the a.odt attachment
2. Scroll up and down while a page boundary is in view

Actual Results:
Scrolling is extremely slow, repagination indication seen again and again

Expected Results:
Scrolling is super-fast and you don't notice the "blue bar" on the page boundary at all


Reproducible: Always


User Profile Reset: No



Additional Info:
See with:

Version: 6.2.0.0.alpha0+
Build ID: ad6adb1bfadf49af3187a0bb3ceffbf355e9eed1
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-29_02:45:20
Locale: en-US (en_IL); Calc: threaded

But I remember this happening for at least a year back, probably a lot more.
Comment 1 Eyal Rozenberg 2018-10-18 22:28:24 UTC
Created attachment 145817 [details]
Document exhibiting the bug

This has three pages and footer numbering (but it used to have a bunch of content - originally it was a PhD thesis of someone and I removed most pages and emptied out the first three)
Comment 2 Shai Berger 2018-10-20 14:30:05 UTC
I Cannot reproduce

Version: 6.1.3.1
Build ID: 1:6.1.3~rc1-1
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-US (en_IL.UTF-8); Calc: group threaded

(from Debian's testing repository)
Comment 3 Eyal Rozenberg 2018-10-20 14:37:07 UTC
(In reply to Shai Berger from comment #2)
I also can't reproduce on my own system, with:

Version: 5.2.7.2
Build ID: 1:5.2.7-1+deb9u4
CPU Threads: 4; OS Version: Linux 4.9; UI Render: default; VCL: gtk3; 
Locale: he-IL (en_IL); Calc: group

Maybe it's a 6.2.x issue?
Comment 4 Weng Jing-Yao 2018-11-29 09:44:03 UTC
I can't reproducible in:

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-01-10 12:54:28 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: b8f497a06d585dbae3adadb4d177fe84fdb1b5fa
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 6 Eyal Rozenberg 2019-01-11 18:01:38 UTC
(In reply to Xisco Faulí from comment #5)
> Could you please try to reproduce it with a master build from
> http://dev-builds.libreoffice.org/daily/master/ ?

I just have, and can no longer reproduce it. Closing as INVALID for now.