Bug 120688 - Formula Editor cannot handle prefix of namespace
Summary: Formula Editor cannot handle prefix of namespace
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MathML
  Show dependency treegraph
 
Reported: 2018-10-18 22:06 UTC by Regina Henschel
Modified: 2020-12-27 14:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
no prefix (286 bytes, application/mathml+xml)
2018-10-18 22:06 UTC, Regina Henschel
Details
prefix m (320 bytes, application/mathml+xml)
2018-10-18 22:06 UTC, Regina Henschel
Details
prefix math (371 bytes, application/mathml+xml)
2018-10-18 22:07 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-10-18 22:06:05 UTC
Created attachment 145814 [details]
no prefix

Open attached "test_mathvariant_no_prefix.mml". It looks fine: 'ln' has got 'func' attribute and 'e' is non-italic.

Open attached "test_mathvariant_prefix_m". It opens in Writer. And if you set the import filter to "MathML", then it opens in Math module, but 'e' is italic.

Open attached "test_mathvariant_prefix_math". 'e' is italic.

The files only differ in whether the namespace is prefixed, and what is used as prefix.
Comment 1 Regina Henschel 2018-10-18 22:06:34 UTC
Created attachment 145815 [details]
prefix m
Comment 2 Regina Henschel 2018-10-18 22:07:08 UTC
Created attachment 145816 [details]
prefix math
Comment 3 Buovjaga 2018-12-27 16:32:32 UTC
(In reply to Regina Henschel from comment #0)
> Open attached "test_mathvariant_prefix_math". 'e' is italic.

Confirmed.

I cannot get test_mathvariant_prefix_m to open in Math even though I specify the MathML filter from the file open dialog.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 3bc65fe56d726de2b6efe229daedb634df940ce8
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 26 December 2018

Win 10
LibreOffice 3.3.0
Comment 4 QA Administrators 2020-12-27 03:37:10 UTC Comment hidden (obsolete)
Comment 5 Regina Henschel 2020-12-27 14:57:18 UTC
Now <mo>&#x2061;</mo> is no longer translated to operator 'func'.

Automatic type detection still not work for 'prefix m' and 'prefix math'.

Tested with Version: 7.2.0.0.alpha0+ (x64)
Build ID: ad9e04321df25824d2288a2ef1f4275f070f1cf7
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL