Bug 120693 - Firebird Migration: Number [ NUMERIC ] Field Data Errors
Summary: Firebird Migration: Number [ NUMERIC ] Field Data Errors
Status: RESOLVED DUPLICATE of bug 116893
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-19 04:35 UTC by sdritchey
Modified: 2018-10-19 06:52 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdritchey 2018-10-19 04:35:33 UTC
Description:
In testing a copy of my existing database that has been migrated to Firebird, I've noticed some apparently random Number [ NUMERIC ] field data being corrupted. Typical entries for my Table would look something like (0.50, 3.00, 10.00, 55.00 or similar).

Post migration all entries with the previous value of 3.00 are showing -652.36, previous values of 4.00 are showing -651.36, and previous values of 5.00 are showing -650.36. All other numeric entries appear to be correct.

Steps to Reproduce:
1. Convert existing HSQLDB to Firebird
2. Open data Table
3. View NUMERIC field data and errors

Actual Results:
NUMERIC Table fields showed errors

Expected Results:
NUMERIC Table fields should show correct NUMERIC data.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Alex Thurgood 2018-10-19 06:52:54 UTC
@sdritchey: there is already at least one bug report about incorrect migration of numeric data type

*** This bug has been marked as a duplicate of bug 116893 ***