Bug 120764 - gtk 3.24/Wayland: Toolbar popups not working when a tooltip is visible
Summary: gtk 3.24/Wayland: Toolbar popups not working when a tooltip is visible
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:6.2.0 target:6.1.4
Keywords:
Depends on:
Blocks: Wayland
  Show dependency treegraph
 
Reported: 2018-10-22 02:56 UTC by Roger T. Imai
Modified: 2018-10-30 09:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger T. Imai 2018-10-22 02:56:49 UTC
Description:
The Font selection and Font Size selection dropdown menus in the toolbar do not respond to click (press) on the down-arrow buttons.

Selectively disabling Hardware Acceleration and Antialiasing in Tools > Options > View has no effect. ('Use OpenGL' option no longer appears in Graphics options.) Dropdown arrow-buttons work fine under X11. Dropdown menus in the main menubar also work as expected under Wayland. I have only Writer and Calc modules installed, but this symptom may appear in all toolbars of the full LO installation. Workaround: use main menubar.

release: Ubuntu 18.10
kernel: 4.18.0-10-generic
GNOME Shell 3.30.1
session: ubuntu [gnome-wayland]
LibreOfice Version: 6.1.2.1
Build ID: 1:6.1.2-0ubuntu1
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded


Steps to Reproduce:
1. Click on Font Selection down-arrow button.
2. Click on Font Size Selection down-arrow button.
3. 

Actual Results:
Toolbar buttons are unresponsive.

Expected Results:
Dropdown menus should appear. They don't.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Maxim Monastirsky 2018-10-22 23:32:07 UTC
This might help:

https://gerrit.libreoffice.org/62207/
Comment 2 Roger T. Imai 2018-10-23 07:35:35 UTC
Yes, I can confirm that Maxim has isolated the cause (thank you) -- tooltips. I would never have suspected it. 

I don't think I'm qualified to change the status of this bug, and assume that it will be marked "Resolved" when a patch is released.
Comment 3 Maxim Monastirsky 2018-10-23 11:49:04 UTC
Thanks for confirming.
Comment 4 Commit Notification 2018-10-24 20:09:32 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8bf751f9f5e2cb718175c0f2c4b2be762dcf614

tdf#120764 Toolbar popups sometimes not showing under Wayland

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Maxim Monastirsky 2018-10-24 20:23:33 UTC
This seems to work for me. Backport request to 6.1 is in gerrit.
Comment 6 Commit Notification 2018-10-30 09:32:38 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/dbd0291e9f1e97c33a6830509ef503159aa6e063%5E%21

tdf#120764 Toolbar popups sometimes not showing under Wayland

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.