Bug 120782 - Crash when dragging column from datasource to spreadsheet
Summary: Crash when dragging column from datasource to spreadsheet
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2018-10-22 10:28 UTC by Xisco Faulí
Modified: 2018-10-30 20:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (9.72 KB, text/plain)
2018-10-28 20:34 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-10-22 10:28:58 UTC
This is a follow-up of bug 118963 which got fixed in http://cgit.freedesktop.org/libreoffice/core/commit/?id=e5ee79b5c089e72e6b24c04c7c820d706bd39993.
However it's now reproducible in master again...

- Start spreadsheet
- Open data source (Ctrl+F4)
- Select column & drag to sheet
  > Crash

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 5fb66ae5595b7435e8954df31473fad15a74b8c2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 1 Xisco Faulí 2018-10-22 10:30:12 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f2bd68c33c13b94cf844227d04a7eba9fe3723f8

author	Julien Nabet <serval2412@yahoo.fr>	2018-09-30 01:25:48 +0200
committer	Julien Nabet <serval2412@yahoo.fr>	2018-10-07 21:19:52 +0200
commit	f2bd68c33c13b94cf844227d04a7eba9fe3723f8 (patch)
tree	fcb89611ad4b3571b488f759014a2cf9ef7893a5
parent	45385a532b2d4bd227d6771e54b2b8a9faca939c (diff)
tdf#120152: fix adding labels in reportdesign

Bisected with: bibisect-linux64-6.2

Adding Cc: to Julien Nabet
Comment 2 Xavier Van Wijmeersch 2018-10-22 13:33:29 UTC
confirm with

crashreport.libreoffice.org/stats/crash_details/5a8dcbb4-4120-4556-b89f-53374f8cbc02

Version: 6.2.0.0.alpha1+
Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-10-22_00:35:58
Locale: nl-BE (en_US.UTF-8); Calc: threaded
Comment 3 Julien Nabet 2018-10-24 18:08:32 UTC
Sorry, I'm lost about all this and will stay away now from this mess.
Feel free to revert the patch.
Comment 4 Julien Nabet 2018-10-28 20:34:24 UTC
Created attachment 146108 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 5 Julien Nabet 2018-10-28 20:50:24 UTC
I submitted this to review:
https://gerrit.libreoffice.org/#/c/62482/
If it's gerrit is ok, I'll push this.

I'm still not sure if it's ok but since I don't reproduce the crash with it and I've got same behaviour than in an old version with no crash...

Of course, if someone is against it because not the right patch or anything else, don't hesitate to revert it.
Comment 6 Commit Notification 2018-10-28 23:00:08 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a73f696b9a36b85ac6549a3a342a690eefcec4fc%5E%21

tdf#120782: fix crash when dragging column...

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2018-10-29 11:17:49 UTC
Hi Julien,
Thanks for providing the patch.
However I still see a couple a problem that I can't reproduce before https://cgit.freedesktop.org/libreoffice/core/commit/?id=f2bd68c33c13b94cf844227d04a7eba9fe3723f8

1. If I drag&drop a column to the spreadsheet and undo the action, it's not reverted.
2. Once I've tried to undo it, if I insert drag&drop another column, LibreOffice crashes...
Comment 8 Commit Notification 2018-10-30 09:23:13 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f88b95032262c434647475b6af7e33068635b6c4%5E%21

Revert tdf#120782, tdf#120728, tdf#120152, tdf#120151

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Julien Nabet 2018-10-30 09:26:15 UTC
I gave a try with it and could do the drag, the undo and do another drag.
Don't hesitate to reopen this tracker if I missed something.
Comment 10 Xisco Faulí 2018-10-30 20:26:59 UTC
Verified in

Version: 6.2.0.0.alpha1+
Build ID: 612e8f05d72b96c86122396ffc960cd76a742325
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded