Bug Hunting Session
Bug 120859 - csv import dialog: Overlapping labeltexts and checkbox
Summary: csv import dialog: Overlapping labeltexts and checkbox
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.1.5 target:6.2.0.1
Keywords:
: 120975 122677 (view as bug list)
Depends on:
Blocks: CSV-Dialog
  Show dependency treegraph
 
Reported: 2018-10-24 08:26 UTC by Martin Vogel
Modified: 2019-01-13 09:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the german CSV import dialog (67.60 KB, image/png)
2018-10-24 08:26 UTC, Martin Vogel
Details
not reproducible in Catalan (54.39 KB, image/png)
2018-10-30 12:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Vogel 2018-10-24 08:26:35 UTC
Created attachment 145960 [details]
Screenshot of the german CSV import dialog

In the CSV import dialog of the german translation of Calc the labeltext "Feldtrennzeichen zusammenfassen" overlaps the next checkbox and its labeltext "Leeräume beschneiden". The latter checkbox cannot be selected by clicking into the box.
Comment 1 Oliver Brinzing 2018-10-27 09:26:43 UTC
confirming with:

Version: 6.1.3.1 (x64)
Build-ID: a9670562c26181ec3afbe381c9ff499ae88c98b7
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc:
Comment 2 Oliver Brinzing 2018-10-28 08:54:47 UTC
*** Bug 120975 has been marked as a duplicate of this bug. ***
Comment 3 Xisco Faulí 2018-10-30 12:30:48 UTC
Created attachment 146167 [details]
not reproducible in Catalan
Comment 4 Xisco Faulí 2018-10-30 12:31:20 UTC
@Caolán, I thought you could be interested in this issue...
Comment 5 Caolán McNamara 2018-12-19 12:17:31 UTC
There are odd column span values on those overlapping widgets in the .ui I think it may have gone wrong at https://cgit.freedesktop.org/libreoffice/core/commit/?id=d999b55e28d0445df870f69b3a269964e3635def
Comment 6 Commit Notification 2018-12-19 15:50:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5068527d417fc28869569a35e5881b3390cc48c2%5E%21

tdf#120859 bad column span in .ui leads to overlapping checkbuttons

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-12-19 16:04:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/d5fd1538890dee3ba1b6564a1e657046518f44d3%5E%21

tdf#120859 bad column span in .ui leads to overlapping checkbuttons

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2018-12-19 16:31:59 UTC
backport to 6-2 in gerrit
Comment 9 Commit Notification 2018-12-19 20:12:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3b9e0998163c9af5e7d94e92f8375a5748a05a8a%5E%21

tdf#120859 bad column span in .ui leads to overlapping checkbuttons

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Oliver Brinzing 2019-01-13 09:34:26 UTC
*** Bug 122677 has been marked as a duplicate of this bug. ***