Download it now!
Bug 120938 - Function “Navigate By” does not Work Correctly with Reminders
Summary: Function “Navigate By” does not Work Correctly with Reminders
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0
Keywords:
Depends on:
Blocks: Navigate-By
  Show dependency treegraph
 
Reported: 2018-10-26 12:09 UTC by Harald Koester
Modified: 2020-01-17 02:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with instructions in order to reproduce the bug (15.09 KB, application/vnd.oasis.opendocument.text)
2018-10-26 12:09 UTC, Harald Koester
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-10-26 12:09:29 UTC
Created attachment 146030 [details]
Example file with instructions in order to reproduce the bug

In order to reproduce the bug open the attached document and follow the instructions inside the document.

The Navigate By function already exists in version 3.3.0. But how to seize this function has been changed during the different versions. This bug already exists in version 3.3.0. Thus inherited from OOo.
Comment 1 Dieter 2018-10-26 13:55:57 UTC
Reproducible with

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-22_01:47:50
Locale: en-US (de_DE); Calc: CL

Jim, also one for you? (cc: Jim Raykowski)
Comment 2 Jim Raykowski 2018-10-31 00:32:04 UTC
Looks like Reminder navigation is based on the previous Reminder navigated to and not current location of the cursor.
Comment 3 QA Administrators 2019-11-01 03:37:06 UTC Comment hidden (obsolete)
Comment 4 Harald Koester 2019-11-22 12:53:44 UTC
Bug still exists in version 6.3.3 (64 bit, Win10).
Comment 5 Jim Raykowski 2020-01-11 05:10:23 UTC
I believe this is NAB and that by design reminders are navigated by the order set and from the last reminder visited. My belief of this comes from work done to fix bug 88713.
Comment 6 sdc.blanco 2020-01-11 11:48:49 UTC
(In reply to Jim Raykowski from comment #5)
> I believe this is NAB and that by design reminders are navigated by the
> order set and from the last reminder visited.
Thanks for the clarification Jim, which you also gave in comment #2.

So maybe this report should become a "documentation" request?

I could add a "notetext"  (a separate box under "Set Reminder") on:
https://help.libreoffice.org/latest/en-US/text/swriter/01/02110000.html

like:  "Reminders are navigated in the order in which they are set"

@Jim -- maybe "last reminder visited" is not needed in this notetext? Afaik, it is not possible to visit a reminder arbitrarily, so "next" reminder will always be according to the order. (trying to get the statement to be simple, but not too simple)

I could also add that sentence at: 
https://help.libreoffice.org/latest/en-US/text/swriter/01/02110100.html

These are the only places in "help" where I could find reminders mentioned.
Comment 7 Jim Raykowski 2020-01-11 21:51:48 UTC
(In reply to sdc.blanco from comment #6)

> like:  "Reminders are navigated in the order in which they are set"
> 
> @Jim -- maybe "last reminder visited" is not needed in this notetext? Afaik,
> it is not possible to visit a reminder arbitrarily, so "next" reminder will
> always be according to the order. (trying to get the statement to be simple,
> but not too simple)
> 

Simple but not too simple sounds good to me ;-)

It bothers me that to revisit the last reminder set requires a next/previous combination when there is more than one reminder. Maybe next/previous should go to the last reminder set if not already there?
Comment 8 sdc.blanco 2020-01-11 23:17:43 UTC
(In reply to Jim Raykowski from comment #7)
> Maybe next/previous should go to the last reminder set if not already there?
Would probably not make a big difference to me -- because usually I only use 1 or 2 reminders (3 in a rare instance). They are lost anyway, and navigation is easy this way.  ("save and reload" serves as "reset" button).
Comment 9 Commit Notification 2020-01-12 16:13:54 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/539e836b676ca3516603a85652b9323e0ca91ecb

tdf#120938 clarify how reminders navigate
Comment 10 sdc.blanco 2020-01-17 00:15:17 UTC
(In reply to Jim Raykowski from comment #5)
> I believe this is NAB and that by design reminders are navigated by the
> order set and from the last reminder visited. My belief of this comes from
> work done to fix bug 88713.
(just checking...) Did you mean to set resolution as FIXED? instead of NOTABUG?
Comment 11 Jim Raykowski 2020-01-17 02:08:41 UTC
I didn't see NOTABUG available to me when I set this as FIXED. I have changed it to NOTABUG. Thanks for asking.