Download it now!
Bug 120942 - Calc crashes when copying multiple rows, if Ditto app is running
Summary: Calc crashes when copying multiple rows, if Ditto app is running
Status: RESOLVED DUPLICATE of bug 118416
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-26 14:43 UTC by Chad Cloman
Modified: 2018-12-29 17:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test file that causes the error (14.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-10-26 14:43 UTC, Chad Cloman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chad Cloman 2018-10-26 14:43:59 UTC
Created attachment 146037 [details]
Test file that causes the error

1. Install and run the Ditto app for Windows 10 (https://www.microsoft.com/en-us/p/ditto-clipboard/9nblggh3zbjq)
2. Open attached Calc document
3. Select multiple rows by clicking and dragging the mouse in the left-hand column with the row numbers. For example, rows 4 through 6. You must select the entire row.
4. Press Ctrl-C to copy, or select "Copy" from the "Edit" menu.
5. LibreOffice terminates. When you restart, it asks to send a bug report and starts the recovery process.

If you exit Ditto (via the system tray) and repeat steps 2-5, LibreOffice does not crash.

If you select one row, LibreOffice does not crash.
Comment 1 Xisco Faulí 2018-11-26 15:45:40 UTC
I can't reproduce it in

Versión: 6.1.3.2
Id. de compilación: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Xisco Faulí 2018-11-26 15:48:15 UTC
It could be a duplicate of bug 118416.
Please try with LibreOffice 6.1.3.2
Regards
Comment 3 Steve Magruder 2018-11-28 15:10:58 UTC
I was experiencing something similar to this on Windows 10 before I upgraded to 6.1.3.2, except Calc hung and then the whole OS hung, and I had to do a hard shutdown, as even Ctrl-Alt-Del wouldn't work.
Comment 4 Chad Cloman 2018-11-30 18:23:27 UTC
I reproduced this on 6.0.6.2, then installed 6.1.3.2 and the error did not occur. Marking it as resolved and a duplicate of 118416. Thank you for investigating.

*** This bug has been marked as a duplicate of bug 118416 ***
Comment 5 Steve Magruder 2018-12-29 17:15:34 UTC
I have to mostly retract my last comment.  I'm still getting the system hangs when selecting a number of rows or columns and doing Ctrl-C when Ditto is running, although the hangs eventually work themselves out and I don't have to reboot.