Bug Hunting Session
Bug 121029 - The table borders using the table picker tool is slightly different from Table Insert
Summary: The table borders using the table picker tool is slightly different from Tabl...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Table-Borders
  Show dependency treegraph
 
Reported: 2018-10-29 15:38 UTC by Telesto
Modified: 2018-11-30 10:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (3.07 KB, text/plain)
2018-11-29 21:31 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-10-29 15:38:26 UTC
Description:
The table size using the table drag tool is slightly different from Table Insert

Steps to Reproduce:
1. Insert a 2x10 table with the table picker
2. Select the table
3. Right click the table -> Table -> Choose default style (notice a shift) (alternative; use the sidebar table style panel)

Actual Results:
Small shift applying the default style

Expected Results:
Table picker tool should use the default style (I suppose)


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha1+
Build ID: cb7500ddb8de6c41fca84a0009ffe22240bb1845
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-29_03:24:02
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Durgapriyanka 2018-11-29 16:29:15 UTC
Can not reproduce in 

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 2 Telesto 2018-11-29 17:00:44 UTC
1. Insert a 2x10 table with the table picker
2. Select the table
3. Right click the table -> Table -> Choose default style
4. Notice that the table is expanding (vertically)
5. If needed press CTRL+Z & CTRL+Y a few times to see it


Version: 6.3.0.0.alpha0+
Build ID: f21d2b48bd68424a96aa6cd5572e368208378291
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-11-27_00:26:54
Locale: en-US (nl_NL); UI-Language: en-US
Calc: CL
Comment 3 Dieter Praas 2018-11-29 20:53:11 UTC
I confirm it with

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

This happens because of different width of table borders
table picker: Table border 0,05pt
default style: Table border 0,5pt

Table borders of table with table picker should also have 0,5pt
Comment 4 Telesto 2018-11-29 21:10:19 UTC
(In reply to Dieter Praas from comment #3)
> I confirm it with
> 
> Version: 6.2.0.0.beta1 (x64)
> Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
> CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> Locale: en-US (de_DE); UI-Language: en-GB
> Calc: threaded
> 
> This happens because of different width of table borders
> table picker: Table border 0,05pt
> default style: Table border 0,5pt
> 
> Table borders of table with table picker should also have 0,5pt

@Jim
You're the table style expert ;-). So I thought you might be interested..
Comment 5 Telesto 2018-11-29 21:31:57 UTC Comment hidden (obsolete)
Comment 6 Telesto 2018-11-29 21:33:17 UTC Comment hidden (obsolete)
Comment 7 Dieter Praas 2018-11-29 21:40:59 UTC
Also repro in

Version: 6.1.3.2 (x64)
Build-ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded
Comment 8 Jim Raykowski 2018-11-30 00:35:47 UTC
(In reply to Telesto from comment #4)
> (In reply to Dieter Praas from comment #3)
> > I confirm it with
> > 
> > Version: 6.2.0.0.beta1 (x64)
> > Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
> > CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> > Locale: en-US (de_DE); UI-Language: en-GB
> > Calc: threaded
> > 
> > This happens because of different width of table borders
> > table picker: Table border 0,05pt
> > default style: Table border 0,5pt
> > 
> > Table borders of table with table picker should also have 0,5pt
> 
> @Jim
> You're the table style expert ;-). So I thought you might be interested..

Thank you for the compliment but... really I'm no expert, just enjoy hacking on LO and being a part of this awesome community :-)

Guessing the "table picker" is the insert table tool button. The button that inserts a table with no style. If so, it is plausible the cause of the shift is as Dieter has pointed out. 

Tables inserted with the insert table tool button have no style. Table Default Style is an auto format table style. When a table style is applied to a table any direct formatting is replaced by the table style when rows or columns are added/deleted. We tried using Default Style as the default for newly inserted tables. Probably shouldn't do that again. It may hold the record for the most bug reports :(, see bug 115573
Comment 9 Dieter Praas 2018-11-30 08:16:53 UTC
Jim, so taking your commetn into account, what is your suggestion for this bug?
Comment 10 Jim Raykowski 2018-11-30 09:37:54 UTC
IMHO NAB because Default Table style and no table style are not the same. When Default Table style is applied to a table with no style the slight expansion might be viewed as a subtle hint to an observant user that something has been done to the table. It may have been purposely design this way?
Comment 11 Dieter Praas 2018-11-30 10:13:26 UTC
(In reply to Jim Raykowski from comment #10)
> IMHO NAB because Default Table style and no table style are not the same.
> When Default Table style is applied to a table with no style the slight
> expansion might be viewed as a subtle hint to an observant user that
> something has been done to the table. It may have been purposely design this
> way?

I agree, that Default table style and no table style can or should look different. But actually the defference is so minimal that perhaps a lot of users think it's the same. So what I would expect (regarding your explanations) is that using the table picker has the same result than choosing "none style" in the insert dialog.
Comment 12 Jim Raykowski 2018-11-30 10:34:23 UTC
(In reply to Dieter Praas from comment #11) 
> So what I would expect (regarding your
> explanations) is that using the table picker has the same result than
> choosing "none style" in the insert dialog.

I would also expect this but after checking I see that a no style table inserted with the table picker has borders and a no style table inserted with the Insert Table dialog has no borders. I would think for consistency both should have the same?
Comment 13 Dieter Praas 2018-11-30 10:47:22 UTC
(In reply to Jim Raykowski from comment #12)
 
> I would also expect this but after checking I see that a no style table
> inserted with the table picker has borders and a no style table inserted
> with the Insert Table dialog has no borders. I would think for consistency
> both should have the same?

So my suggestion is to close this as NAB. I've opened a new report (bug 121816) about the difference you mentioned.
If somebody doesn't agree, feel free to reopen the report.