Bug 121045 - FILEOPEN DOCX OLE form control checkbox is larger than in Word
Summary: FILEOPEN DOCX OLE form control checkbox is larger than in Word
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: DOCX-Tables DOCX-ActiveX-Legacy Form-Controls
  Show dependency treegraph
 
Reported: 2018-10-29 22:54 UTC by Gabor Kelemen (allotropia)
Modified: 2020-03-13 08:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example document from Word with legacy form control checkboxes (67.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-29 22:54 UTC, Gabor Kelemen (allotropia)
Details
The document in Word (172.72 KB, image/png)
2018-10-30 08:16 UTC, Gabor Kelemen (allotropia)
Details
The document in LO 6.2 (207.67 KB, image/png)
2018-10-30 08:17 UTC, Gabor Kelemen (allotropia)
Details
Minimized version of the file from Word (27.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-02-17 13:30 UTC, NISZ LibreOffice Team
Details
Screenshot of the minimized document in Writer and Word (122.87 KB, image/png)
2020-02-17 13:34 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2018-10-29 22:54:48 UTC
Created attachment 146152 [details]
Example document from Word with legacy form control checkboxes

Attached form has a lot of legacy OLE form control checkboxes in tables.

In Word this document fits on 3 pages, but in Writer it is 5.

This is because the legacy form controls are imported as a slightly larger square, causing table rows becoming a bit taller. 
This adds up and two table rows are pushed to the next page after the first one, and an empty paragraph is pushed to the fourth page.

It would be nice if these old style controls would be somehow identical in size to the ones in Word.

Note: the square before "Kulcs visszaállítás" on the first page is actually smaller than all other squares, while in Word it is the same size.
Comment 1 Gabor Kelemen (allotropia) 2018-10-30 08:16:42 UTC
Created attachment 146158 [details]
The document in Word
Comment 2 Gabor Kelemen (allotropia) 2018-10-30 08:17:12 UTC
Created attachment 146159 [details]
The document in LO 6.2

Version: 6.2.0.0.alpha1+
Build ID: b6b31bbb1a9e2272ac77de127825c4ee9f71effa
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); Calc: CL
Comment 3 Dieter 2018-10-30 16:11:32 UTC
I confirm it with

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-22_01:47:50
Locale: en-US (de_DE); Calc: CL
Comment 4 Xisco Faulí 2018-10-31 13:21:03 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 5 NISZ LibreOffice Team 2020-02-17 13:30:50 UTC
Created attachment 157947 [details]
Minimized version of the file from Word

This small 1x2 table shows the problem too.
Comment 6 NISZ LibreOffice Team 2020-02-17 13:34:12 UTC
Created attachment 157948 [details]
Screenshot of the minimized document in Writer and Word

For some reason the box in the left cell has 12pt character size in Writer, but only 10pt in Word. 
The box in the right cell has 10pt character size in both.

Also if the cell contents are copy-pasted into the document body both boxes get 12pt character size in Word and Writer too.
Comment 7 NISZ LibreOffice Team 2020-02-17 13:35:17 UTC
Adding to docx+table meta, this problem might have to do something with tables.
Comment 8 Commit Notification 2020-02-24 12:45:45 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/22ad4d69d771708f28a2d9e137cfd43ac846cf3a

tdf#121045 DOCX import: fix checkbox size in table

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Dieter 2020-03-13 08:50:08 UTC
Verified with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: c63148ba139bd6b9ae7a0f9e24e51f29e5370963
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

László, thanks for fixing it!