Bug 121074 - Missing images in an XLSX on Linux and macOS (OK on Windows)
Summary: Missing images in an XLSX on Linux and macOS (OK on Windows)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2018-10-31 09:41 UTC by Mike Kaganski
Modified: 2018-12-09 13:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file with images missing on import on Linux/macOS (76.72 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-10-31 09:41 UTC, Mike Kaganski
Details
Screenshot on Ubuntu 18.04 (195.23 KB, image/png)
2018-10-31 09:41 UTC, Mike Kaganski
Details
Screenshot on Windows 10 (266.26 KB, image/png)
2018-10-31 09:42 UTC, Mike Kaganski
Details
ms excel 2016 (42.40 KB, image/jpeg)
2018-11-01 09:55 UTC, Oliver Brinzing
Details
console logs (3.13 KB, text/plain)
2018-11-01 18:03 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2018-10-31 09:41:23 UTC
Created attachment 146185 [details]
Sample file with images missing on import on Linux/macOS

The attached sample has 3 images over cells A5, A6, and A7. They are visible in MS Excel, and in LO on Windows; but when open in LO on Ubuntu 16.04, 18.04, or on macOS, the images are missing [1].

Tested myself with Version: 6.1.2.1
Build ID: 1:6.1.2~rc1-0ubuntu0.18.04.1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: 

Also tested on Windows to confirm that it shows images there with Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 12; OS: Windows 10.0; UI render: GL; 
Locale: ru-RU (ru_RU); Calc: CL

[1] Original report: http://forumooo.ru/index.php/topic,7353 (Russian)
Comment 1 Mike Kaganski 2018-10-31 09:41:59 UTC
Created attachment 146186 [details]
Screenshot on Ubuntu 18.04
Comment 2 Mike Kaganski 2018-10-31 09:42:57 UTC
Created attachment 146187 [details]
Screenshot on Windows 10
Comment 3 Jan-Marek Glogowski 2018-10-31 12:47:16 UTC
First bugreport I see, where something is broken on all platforms _except_ Windows :-) 

And I can confirm I don't see the included images on todays master, neither in the document, nor in the navigator.

Version: 6.2.0.0.alpha1+
Build-ID: d72c915794eb4453dc580fc0dcdfbe3503a4879b
CPU-Threads: 64; BS: Linux 3.16; UI-Render: Standard; VCL: x11; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: threaded

In the terminal I see:
warn:legacy.osl:19680:19680:oox/source/helper/graphichelper.cxx:119: GraphicHelper::GraphicHelper - cannot get target frame
Comment 4 Oliver Brinzing 2018-11-01 09:47:12 UTC
excel 2016 complains attached *.xslx is corrupted, will not open ....
seems to be created with Microsoft Excel Online/16.0300
Comment 5 Mike Kaganski 2018-11-01 09:49:28 UTC
(In reply to Oliver Brinzing from comment #4)

Just re-tested with Excel 2016 on Win10, and received no warnings/errors.
Comment 6 Oliver Brinzing 2018-11-01 09:55:52 UTC
Created attachment 146216 [details]
ms excel 2016

tried again, same result ... opens fine with lo 6.1.3.1 ...

D:\>md5sum price_bitiy_obrazets-1.xlsx
10fdef01e4a87eb25fcc344917d5d9de *price_bitiy_obrazets-1.xlsx
Comment 7 Oliver Brinzing 2018-11-01 10:13:55 UTC
excel tried top open file in protected view (https://support.office.com/en-us/article/what-is-protected-view-d6f09ac7-e6b9-4495-8e43-2bbcdbcb6653) and fails.
after changing file properties, it will open.
Comment 8 Julien Nabet 2018-11-01 18:03:25 UTC
Created attachment 146230 [details]
console logs

On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.

I attached console logs:
warn:legacy.osl:3913:3913:oox/source/helper/graphichelper.cxx:119: GraphicHelper::GraphicHelper - cannot get target frame
warn:oox:3913:3913:oox/source/drawingml/shapecontext.cxx:129: ShapeContext::onCreateContext: unhandled element: 2146
warn:oox:3913:3913:oox/source/drawingml/shapecontext.cxx:129: ShapeContext::onCreateContext: unhandled element: 2144
warn:legacy.osl:3913:3913:sc/source/filter/oox/worksheethelper.cxx:533: WorksheetGlobals::getDrawPageSize - called too early, size invalid
Comment 9 Xisco Faulí 2018-11-02 17:52:35 UTC
Seems to be inherit from OOo.
I see the images in

LibreOffice 3.3.0 Win
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

but not in

LibreOffice 3.3.0 Linux
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4