Bug Hunting Session
Bug 121104 - FIREBIRD: No connection to external Firebird-file in Windows possible
Summary: FIREBIRD: No connection to external Firebird-file in Windows possible
Status: RESOLVED DUPLICATE of bug 115547
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-01 20:43 UTC by Robert Großkopf
Modified: 2018-11-01 23:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
External firebird database for testing (87.83 KB, application/zip)
2018-11-01 20:43 UTC, Robert Großkopf
Details
First error (16.17 KB, image/png)
2018-11-01 20:44 UTC, Robert Großkopf
Details
Connection working after file:/// is removed (22.96 KB, image/png)
2018-11-01 20:45 UTC, Robert Großkopf
Details
No permission to access to table (9.48 KB, image/png)
2018-11-01 20:45 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2018-11-01 20:43:32 UTC
Created attachment 146232 [details]
External firebird database for testing

Download the attached database-file (*.zip-package).
Open LO under Windows.
Base > Connect to external database > Firebird file
Choose the file, save the database-file (registering not needed).
Try to connect to the tables.
You will get this error:
--------------------
firebird_sdbc error:
*Unable to complete network request to host ...
--------------------
Now open Edit > Database > Properties and delete in the path "file:///"
Press OK and try to connect again.
The tables will be shown.
Try to open one of the tables.
You will get the error
--------------------
firebird_sdbc error:
*no permission for SELECT access to TABLE ...
--------------------
Connection is working well under Linux. Connection fails under Windows 7 and Windows 10, reported to me from other users.

All tested with LO 6.1.3.2
Comment 1 Robert Großkopf 2018-11-01 20:44:32 UTC
Created attachment 146233 [details]
First error
Comment 2 Robert Großkopf 2018-11-01 20:45:12 UTC
Created attachment 146234 [details]
Connection working after file:/// is removed
Comment 3 Robert Großkopf 2018-11-01 20:45:48 UTC
Created attachment 146235 [details]
No permission to access to table
Comment 4 Gerhard Weydt 2018-11-01 21:06:56 UTC
Can confirm with 6.1.3.2

and also with 6.2:
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-01_03:18:33
Locale: de-DE (de_DE); Calc: threaded
Comment 5 Drew Jensen 2018-11-01 23:13:55 UTC
(In reply to Gerhard Weydt from comment #4)
> Can confirm with 6.1.3.2
> 
> and also with 6.2:
> Version: 6.2.0.0.alpha0+ (x64)
> Build ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
> CPU threads: 4; OS: Windows 10.0; UI render: GL; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-01_03:18:33
> Locale: de-DE (de_DE); Calc: threaded


I believe this is a duplicate of "Firebird: Link is formed to an external file with file:///C: (three slash)" https://bugs.documentfoundation.org/show_bug.cgi?id=115547 also windows only.

*** This bug has been marked as a duplicate of bug 115547 ***