Download it now!
Bug 121162 - Wrong Section is Found with Function “Navigate By” if Cursor is Located in Header or Footer
Summary: Wrong Section is Found with Function “Navigate By” if Cursor is Located in He...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigate-By
  Show dependency treegraph
 
Reported: 2018-11-04 17:05 UTC by Harald Koester
Modified: 2019-01-12 20:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document with instructions how to reproduce the bug (12.26 KB, application/vnd.oasis.opendocument.text)
2018-11-04 17:05 UTC, Harald Koester
Details
New example file with new instructions (15.51 KB, application/vnd.oasis.opendocument.text)
2019-01-12 20:27 UTC, Harald Koester
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-11-04 17:05:36 UTC
Created attachment 146299 [details]
Example document with instructions how to reproduce the bug

In order to reproduce the bug open the attached document and follow the instructions inside the document.

The function “Navigate By” already exists in version 3.3.0. But how to seize this function has been changed over time. This bug already exists similar in version 3.3.0. Thus inherited from OOo.
Comment 1 Dieter 2018-11-04 21:15:25 UTC
I confirm the described behaviour but I don't think that this is a bug. I think, that it is the normal order of searching:
a) Searching within the "normal" text
b) Searching within header and footer
It's consistent to the search for text. I would say NOTABUG.
Comment 2 Xisco Faulí 2018-11-07 16:23:03 UTC
yep, I agree with Dieter.
Closing as RESOLVED NOTABUG
Comment 3 Harald Koester 2019-01-12 20:27:51 UTC
Created attachment 148275 [details]
New example file with new instructions
Comment 4 Harald Koester 2019-01-12 20:28:44 UTC
I did some more research about this bug report:

If the cursor is in a footer or header, it does not matter on which page, then with a next section search always the first section in a document is found. And with a previous section search always the last section of a document is found.

It is the same if a search for tables instead of sections is performed. Also a search for comments is partly equal.

To my opinion this can't be intended. Hence set status back to UNCONFIRMED.

I added a new example document with new instructions.