Bug 121194 - The last path to export is not remembered on Linux
Summary: The last path to export is not remembered on Linux
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: File-Export-Dialog
  Show dependency treegraph
 
Reported: 2018-11-06 08:53 UTC by Vera Blagoveschenskaya
Modified: 2019-07-14 14:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
video2.mkv (2.14 MB, video/x-matroska)
2018-11-06 08:53 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-11-06 08:53:19 UTC
Description:
The last path to export is not remembered

Steps to Reproduce:
This is a usability bug

1. Create some document in Writer or Calc
2. File -> Save as, select folder 'test1', saving successful.
3. File -> Save as, opens the last folder 'test1' = OK
4. Then, try to export. File -> Export, select another folder 'export1', export successful.
5. One more time File -> Export

Actual Results:
The last path for export is not remembered. LO suggests to save into 'test1' path.

See video in the attachment

Expected Results:
Need to remember the last path to export some document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for 

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded
Comment 1 Vera Blagoveschenskaya 2018-11-06 08:53:39 UTC
Created attachment 146339 [details]
video2.mkv
Comment 2 Timur 2018-11-07 09:40:23 UTC
*** Bug 121220 has been marked as a duplicate of this bug. ***
Comment 3 Timur 2018-11-07 09:42:12 UTC
There were similar reports before, Bug 51618 for Linux resolved as WontFix, Bug 79255 for Windows closed as WFM. Please see.
Comment 4 Vera Blagoveschenskaya 2018-11-07 10:02:16 UTC
Well, I think the problem is not exactly the same as in Bug 51618 

This bug: after Exporting the last path is not remembered, but after Saving it is remembered successfully.
Comment 5 Xisco Faulí 2019-02-07 20:41:49 UTC
Hi Vera,
Could you please try to reproduce it with LibreOffice 6.2.0.3
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 Vera Blagoveschenskaya 2019-02-08 06:23:57 UTC
Hello Xisco,

bug is still reproduced for

Version: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: ru-RU (ru_RU.UTF-8); Calc: group threaded

and for

Version: 6.3.0.0.alpha0+
Build ID: 51af3179cf972809d6495c7d58033e069f647bbf
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-01_00:15:00
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Buovjaga 2019-07-14 14:21:14 UTC
Repro, but not on Windows. Already in the oldest commit of 43all repo.
Someone with a Mac could test as well.

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: 1ce1c26dd98e6477139e08d1ebe89fa950ff5fb0
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 12 July 2019