Bug 121202 - FILEOPEN XLSX The background gradient of cells is incorrectly imported
Summary: FILEOPEN XLSX The background gradient of cells is incorrectly imported
Status: RESOLVED DUPLICATE of bug 49177
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks:
 
Reported: 2018-11-06 11:57 UTC by Gabor Kelemen
Modified: 2018-11-07 16:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Excel with a gradient background cell. (16.41 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-11-06 11:57 UTC, Gabor Kelemen
Details
Screenshot of the original document side by side in Excel and Calc. (160.15 KB, image/png)
2018-11-06 11:58 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-11-06 11:57:30 UTC
Created attachment 146353 [details]
Example file from Excel with a gradient background cell.

The background gradient of cells is incorrectly imported in XLSX spreadsheet created with Microsoft Excel 2010, when we use the Fill Effects option.
Currently it’s not possible to set a gradient background in Calc, only solid color is offered.


Steps to reproduce:

    1. Create a new spreadsheet in Microsoft Excel 2010.
    2. Select and right-click a cell, and then choose Format Cells.
    3. On the Fill tab, click Fill Effects, and then click the option that you want.
    4. Save the file as XLSX.
    5. Open the same file in LibreOffice Calc.

Actual results:
The background gradient of cell is incorrect.

Expected results:
The background gradient of cell should’t change.


LibreOffice details:
Version: 6.2.0.0.alpha0+
Build ID: cf2825d9f8af86a73aae5ac4216966504b320184
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win;
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-15_00:25:36
Locale: en-US (hu_HU); Calc: threaded
Comment 1 Gabor Kelemen 2018-11-06 11:58:00 UTC
Created attachment 146354 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 2 Xisco Faulí 2018-11-07 16:21:05 UTC
I guess this is a duplicate of bug 49177

*** This bug has been marked as a duplicate of bug 49177 ***