Download it now!
Bug 121236 - HANG - scrolling font list dropdown menu with mouse wheel in Insert Special Character causes hang requiring force kill
Summary: HANG - scrolling font list dropdown menu with mouse wheel in Insert Special C...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, perf, regression
: 121928 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-07 10:57 UTC by Alex Thurgood
Modified: 2019-01-14 12:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace from lldb session (23.87 KB, text/plain)
2018-11-07 10:59 UTC, Alex Thurgood
Details
Stacktrace provided by Apple on Macbook Pro (1.87 MB, text/plain)
2018-11-07 11:12 UTC, Alex Thurgood
Details
bt after crash from lldb when scrolling with mouse wheel (1.56 MB, text/plain)
2018-11-15 10:44 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2018-11-07 10:57:14 UTC
Description:
1) Start LibreOffice master
2) Create a new Writer document
3) Menu Insert Special Character
4) Click on the arrow in the dropdown menu of the font list
5) Scroll down with mouse wheel
6) LO attempts to display the font previews, but fails to refresh with the scrolling and eventually goes into a hang loop (spinning beachball).
7) Force kill of LO process required to regain control.

Steps to Reproduce:
See above

Actual Results:
The app grinds to a halt and displays a beachball. The font list is not updated as scrolling is carried out.

Expected Results:
The font list and preview should be displayed smoothly as scrolling progresses


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Alex Thurgood 2018-11-07 10:59:00 UTC
Created attachment 146383 [details]
Backtrace from lldb session
Comment 2 Alex Thurgood 2018-11-07 11:00:31 UTC
For information, I have 236 system fonts installed on this system, all of which were provided by default by Apple.
Comment 3 Alex Thurgood 2018-11-07 11:07:06 UTC
Initial test with Mac Mini 2014 (Core i5 8Gb RAM, Intel Iris graphics).

Reproduced on separate hardware : Macbook Pro 2015 (Core i7, 16Gb RAM, Intel HD4000).
Comment 4 Alex Thurgood 2018-11-07 11:11:38 UTC
(In reply to Alex Thurgood from comment #3)
> Initial test with Mac Mini 2014 (Core i5 8Gb RAM, Intel Iris graphics).
> 
> Reproduced on separate hardware : Macbook Pro 2015 (Core i7, 16Gb RAM, Intel
> HD4000).

Correction graphics chips on Macbook Pro :

Intel Iris Pro
Nvidia Geforce GT750M
Comment 5 Alex Thurgood 2018-11-07 11:12:51 UTC
Created attachment 146384 [details]
Stacktrace provided by Apple on Macbook Pro
Comment 6 Alex Thurgood 2018-11-07 11:17:51 UTC
No repro with 

Version: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
Threads CPU : 8; OS : Mac OS X 10.14; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
Comment 7 Xisco Faulí 2018-11-13 14:46:45 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha1+
Build ID: 2c614b4b2537997aece7ba0aa7ecd38e55fcffaa
CPU threads: 8; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
Locale: en-US (en_ES.UTF-8); UI-Language: en-US
Calc: threaded

is OpenGL enabled ?
Comment 8 Alex Thurgood 2018-11-15 10:42:26 UTC
Still repro with 

Version: 6.2.0.0.alpha1+
Build ID: e3290499009492e39e5ddd870d314bb5df494199
CPU threads: 4; OS: Mac OS X 10.14.1; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Alex Thurgood 2018-11-15 10:44:02 UTC
I finally get a crash with a retrievable bt if I keep trying to scroll down with mouse wheeel through the list of available fonts.
Comment 10 Alex Thurgood 2018-11-15 10:44:57 UTC
Created attachment 146663 [details]
bt after crash from lldb when scrolling with mouse wheel
Comment 11 Alex Thurgood 2018-11-15 10:46:58 UTC
OpenGL isn't enabled by choice, nor is it enabled by default.
Comment 12 Alex Thurgood 2018-11-15 11:07:50 UTC
@Xisco : I see that you're still on macos 10.13 ? I'm on Mojave.
Comment 13 Alex Thurgood 2018-12-06 07:53:06 UTC
*** Bug 121928 has been marked as a duplicate of this bug. ***
Comment 14 Eric Peterson 2018-12-06 20:45:28 UTC
sorry for dupe, first time ever making a bug report...
Downloaded new version 6.1.3.4 today, same problem.

best regards

Eric Peterson
Comment 15 Eric Peterson 2018-12-20 01:40:39 UTC
Thanks for the quick fix!

Best wishes for a happy holiday and a great start on 2019

Eric
Comment 16 Timur 2018-12-21 08:39:42 UTC
121778
Comment 17 Xisco Faulí 2019-01-08 16:02:16 UTC
Hi Alex Thurgood,
Could you please check whether it's a dupe of bug 121778 ?
Comment 18 Alex Thurgood 2019-01-14 12:21:49 UTC
Confirming that this is now WFM in 

Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Mac OS X 10.14.2; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded