Bug Hunting Session
Bug 121256 - [ENHANCEMENT] Display directionality formatting marks
Summary: [ENHANCEMENT] Display directionality formatting marks
Status: RESOLVED DUPLICATE of bug 58434
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-07 19:36 UTC by ajlittoz
Modified: 2018-11-07 21:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ajlittoz 2018-11-07 19:36:48 UTC
Description:
When working in CTL environment, there is sometimes a need to insert a "foreign" word or acronym made of mixed-category characters (Latin letter + symbols within an RTL flow or RTL chars + symbols in LTR flow), like C++. When the "word" can clearly be classified as LTR (or RTL) there is no difficulty. However, if the symbols, which are direction-neutral, lie on the edges of the sequence, their directionality property will be interpreted in the "main text" context, resulting in splitting the "word" into the LTR group + symbols/punctuation concatenated in the "main text". This results in the acronym, like C++, being displayed as ++C.

The workaround is to enclose the sequence between U+200E LEFT-TO-RIGHT MARK and  U+202C POP DIRECTIONAL FORMATTING.

However, there is presently no visual feedback that such marks have been inserted in the text, which makes editing the insert difficult: one needs to erase more than the insert to make sure the marks have been deleted et retype the extra deletion.

The present enhancement requests that the bi-di marks be displayed like "soft hyphen" is (at least when View>Formatting Marks or View>Field Shadings is enabled).

Actual Results:
Presently, no visual clue about directional marks presence

Expected Results:
Wishing a visual feedback about directional marks presence


Reproducible: Always


User Profile Reset: No



Additional Info:
-- This enhancement is presented as a follow-on to bug 121182 and to AskLO question at https://ask.libreoffice.org/en/question/171132/ltr-words-inside-an-rtl-sentence/ --
Comment 1 V Stuart Foote 2018-11-07 21:38:52 UTC

*** This bug has been marked as a duplicate of bug 58434 ***