Bug 121311 - The buttons "convert to ODP format" or "use PPT format" are ordered differently
Summary: The buttons "convert to ODP format" or "use PPT format" are ordered differently
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-09 15:38 UTC by Hanif Bin Ariffin
Modified: 2018-11-13 08:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comparison Linux and Windows (137.04 KB, image/png)
2018-11-12 14:39 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hanif Bin Ariffin 2018-11-09 15:38:16 UTC
Description:
I use both Windows 10 and Ubuntu 18.10. While converting a bunch of .PPT and .DOC files I noticed that the buttons are swapped in the 2 OS tested.
It gets very annoying that the order of the buttons are in different order.

In Ubuntu18.10 "convert to ODP format" comes first. But in W10, it comes second.

Steps to Reproduce:
1. Take any .PPT files
2. Try to save them
3. Libre will prompt to save them as .ODP format
4. Notice the selections are in different order in W10 and Ubuntu18.10

Actual Results:
They are in different order

Expected Results:
The order should be the same across all OSes.


Reproducible: Always


User Profile Reset: No



Additional Info:
I am new to contributing to open-source software. I would like to contribute to this bug but I really don't know where to start
Also, the repository seems to be dying, I can't clone /core
Comment 1 Xisco Faulí 2018-11-12 14:39:02 UTC
Created attachment 146567 [details]
Comparison Linux and Windows
Comment 2 Xisco Faulí 2018-11-12 14:40:12 UTC
I think this is the expected behaviour but I'm not completely sure...
Adding UX team to the loop... Caolán may know the reason as well...
Comment 3 Caolán McNamara 2018-11-12 15:55:01 UTC
"Use ODF Format" is a "cancel" button
"Use Word 97-2003 Format" is a "save" button

as per windows guidelines (also used for kde) the ordering there is 
"save, cancel" so "use..." appears on the right.

gnome guidelines are "cancel, save" so under that "use word..." appears on the right