Bug 121324 - Writer 6.1 thru at least cannot open docx files created by ver. 5.1 or MS Word
Summary: Writer 6.1 thru at least cannot open docx files created by ver. 5.1 o...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
Keywords: filter:docx
Depends on:
Blocks: DOCX-Opening
  Show dependency treegraph
Reported: 2018-11-10 02:08 UTC by Steven Cochran
Modified: 2019-09-12 14:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

LibreOffice test file in docx format (11.21 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-11 06:54 UTC, Steven Cochran
LibreOffice test files in doc & docx formats (9.09 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-11 22:03 UTC, Steven Cochran
set of test files from OP (57.40 KB, application/x-zip-compressed)
2018-11-12 02:34 UTC, V Stuart Foote

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Cochran 2018-11-10 02:08:13 UTC
I have been working with LibreOffice Writer ver. 5.1 for about the last year without a hitch. During the last few weeks I created a 20 page document and saved it in docx format. I got a note saying that ver. 6 was now available, so I decided to upgrade.

    With ver 6.0 when I went back to my docx files created under ver 5.1 I had either blank pages or a few overwritten lines at the top of the file. I thought the files were somehow corrupted: not a pleasant thought. I had printed out the file under ver 5.1 so used Adobe pdf converter to change it to docx format. I fed this back to ver. 6.0 and it came in, understandably, with formatting issues. I beat the files back into shape a page at a time in 6.0. Any docx files created in 6.0 could be read by it, but none of those created by the older ver 5.1. I also tried opening some older docx files created by MS Word with ver. 6.0 and they were also blank or overprinted.  

    Today, I uninstalled ver. 6.0 and installed ver only to discover that it couldn't open docx files either. I uninstalled and installed vere. and, Thank God!!!, I could read my docx files again. Obviously, the file reading bug lies somewhere between ver. and 

    I listed the bug as critical because I have over 1,000 files I couldn't read, but I still love the program and am confident you'll find and kill the bug. In the interim, I'm happy using 

Comment 1 MM 2018-11-10 09:23:32 UTC
Do you have a small test file, so we can check it out ?
Comment 2 V Stuart Foote 2018-11-10 16:34:07 UTC
In addition to posting a sample test file, this is likely a LO user profile problem--a lot of feature changes to styles and templates from 5.1 -> 6.1 releases.

Fortunately, easy to test newer builds without clobbering your 5.1.x profile. Perform an administrative "msiexec /a" install in parallel [1] of 6.1.3 using the TARGETIDR=<path to install> entry and then adjusting the user configuration to "UserInstallation=$ORIGIN/../Data/settings" in the bootstrap.ini file of the TARGETDIR program folder.

Might have a little work to adjust things, but once opening cleanly you can migrate into a new clean user profile.

[1] https://wiki.documentfoundation.org/Installing_in_parallel/Windows
Comment 3 Steven Cochran 2018-11-11 06:54:31 UTC
Created attachment 146534 [details]
LibreOffice test file in docx format

This docx file created in won't open in MS Word
Comment 4 MM 2018-11-11 11:00:33 UTC
Unconfirmed on windows 7 x64 with Version: (x64)
Build ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU threads: 3; OS: Windows 6.1; UI render: default

I can open it normally.
So maybe the userprofile is corrupt, as said in comment 2.
Comment 5 Dieter 2018-11-11 13:41:13 UTC
(In reply to MM from comment #4)
> So maybe the userprofile is corrupt, as said in comment 2.

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile (https://wiki.documentfoundation.org/UserProfile) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 6 Steven Cochran 2018-11-11 22:03:06 UTC
Created attachment 146542 [details]
LibreOffice test files in doc & docx formats
Comment 7 V Stuart Foote 2018-11-12 02:34:33 UTC
Created attachment 146544 [details]
set of test files from OP

Steve sent the attached test files via PM with this note... zipped them up and attached.  I do have issues opening the .DOCX OOXML files with Word 2016--the document does not open. The .DOC version opens, and saving the .DOCX from LO to .ODT, the ODT opens in Word 2016.  -- Stuart  

     I’ve spent the afternoon 11/11/2018 trying to better understand the problem of creating and reading docx and doc files in various versions of LibreOffice. I was never able to find a file or folder labeled User Profile by searching using %APPDATA%\libreoffice\4\user. I did; however, find the LibreOffice folder in Users\\Steve Cochran\AppData\Roaming\LibreOffice. I manually searched all of the sub-folders and never found a folder or file named User Profile. So after I uninstalled each version I manually deleted the LibreOffice folder in AppData to insure each new installation was clean.

I then created short docx and doc test files with each version and fed them to MS Word to see if they would open or could be read. I tried (64 bit); (32 bit); (64 bit); (64 bit)
Test file names are in the form LibreOffice 5-1-0-3 64 Bit docx test file.docx or LibreOffice 5-1-0-3 64 Bit doc test file.doc

Here are the MS Word compatibility Results: (64 Bit) doc: OK font Helvetica (64 Bit) docx: failed no blank pages, just wouldn’t load at all (32 Bit) doc: OK font Helvetica (32 Bit) docx: OK font Helvetica
* 5..4.3.2 (64 Bit) doc: OK font Liberation Serif
* I prefer Helvetica as a font, but when I tried to change it from Liberation Serif to Helvetica
the page went blank. I suspect that Helvetica is not a registered font in version 5.4 – 6.1
5..4.3.2 (64 Bit) docx: OK font Liberation Serif
* (64 Bit) doc: OK font Liberation Serif
* Again Helvetica produces a blank page of an unregistered font (64 Bit) docx: OK font Liberation Serif

Next, I tried backward compatibility by trying to open my test files with ver. (64 Bit) with results shown below: (64 Bit) doc: showed as a blank page with the font as Helvetica (64 Bit) docx: showed as a blank page with the font as Helvetica (32 Bit) doc: showed as a blank page with the font as Helvetica (32 Bit) docx: showed as a blank page with the font as Helvetica (64 Bit) doc: OK with the font as Liberation Serif (64 Bit) docx: OK with the font as Liberation Serif (64 Bit) doc: OK with the font as Liberation Serif (64 Bit) docx: OK with the font as Liberation Serif

I also tried resetting the User Profile through the Help menu in ver. 6.1, but with no change in any result. I wanted to post all of my short test files on Bugzilla, but it wouldn’t accept multiples and in the process I also lost the test description above.

Comment 8 Xisco Faulí 2018-11-12 11:26:54 UTC
I can open all the documents in the zip file attached by Stuart Foote just fine with

Build ID: 0f68e45e2ec6b9fa8c562044e88355d95af0347d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

I'm getting a bit confuse about this bug.
Could anyone tell me which is the file causing problems ?
Comment 9 V Stuart Foote 2018-11-12 12:56:58 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2018-11-12 12:59:32 UTC
(In reply to V Stuart Foote from comment #9)
> Issue is unable to open the LO generated .DOCX/OOXML in MS Word

Even with document created on LibreOffice ?
Comment 11 Timur 2018-11-12 15:21:52 UTC
Not a proper bug report, wrongfully confirmed. 
Because we need a source ODT to be able to test save as DOCX in different versions.
Comment 12 V Stuart Foote 2018-11-12 23:30:01 UTC
Steven, please attach the original "native" .ODT files created in 5.1.03 and/or; not just the .DOC (MS Binary) or .DOCX (OOXML) "save as" that you had problems opening into Word.

Also, which version(s) of MS Word are you using?
Comment 13 Timur 2018-11-14 11:04:51 UTC
Looks like Steven was using docx all the time, without source ODT.
Regardless, we need *exact* reproducible steps showing the problem.
Comment 14 Timur 2019-09-12 14:51:52 UTC
No response so I close. 
We always need native ODT or DOC/X just before issue happened.