Download it now!
Bug 121385 - Bold style missing for arabic text when open .rtf document
Summary: Bold style missing for arabic text when open .rtf document
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:rtf, regression
Depends on:
Blocks: RTF-Styles
  Show dependency treegraph
 
Reported: 2018-11-13 09:45 UTC by seven
Modified: 2021-01-13 11:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (10.61 KB, application/vnd.oasis.opendocument.text)
2018-11-13 09:55 UTC, Xisco Faulí
Details
arabicRT61.rtf: round-tripped by LO 6.1. In MSWord, the first paragraph is bold. (5.70 KB, application/rtf)
2021-01-13 11:25 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description seven 2018-11-13 09:45:34 UTC
Description:
Bold font not set for text when open document

Steps to Reproduce:
Do in Writer:

1. Write or copy from google translate arabic text, for example two string
2. Set first string as bold
3. Save as .rtf document
4. Open saved document and check bold formatting for first string is missed
5. Fix bug, check other product if needed

Actual Results:
Formatting bold text is missed

Expected Results:
Formatting bold text is displayed


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.1.3.1 (x64)
ID сборки: a9670562c26181ec3afbe381c9ff499ae88c98b7
Потоков ЦП: 8; ОС:Windows 10.0; Отрисовка ИП: по умолчанию; 
Локаль: en-US (en_US); Calc: group threaded
Comment 1 Xisco Faulí 2018-11-13 09:55:09 UTC
Created attachment 146585 [details]
sample file
Comment 2 Xisco Faulí 2018-11-13 10:03:59 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fc49c052dbdbb5ab3b0a02a13143705f769b9662

author	Michael Stahl <mstahl@redhat.com>	2014-06-18 00:45:50 +0200
committer	Michael Stahl <mstahl@redhat.com>	2014-06-18 00:48:43 +0200
commit	fc49c052dbdbb5ab3b0a02a13143705f769b9662 (patch)
tree	7d772edb2921cb2be302833cbee7681c44f8ff34
parent	31376a31d12a22d4870bbe4033dbbce18c13f07d (diff)
writerfilter: RTF import: fix handling of associated char properties
These are all dependent on the active \lrtch \rtlch \loch \hich \dbch.
There does not appear to be a SPRM Id for CJK bold / italic / fontsize.

Bisected with: bibisect-44max

Adding Cc: to Michael Stahl
Comment 3 QA Administrators 2020-12-12 03:48:13 UTC Comment hidden (obsolete, spam)
Comment 4 Justin L 2021-01-13 11:15:05 UTC
This has basically been fixed in 6.3 thanks to bug 125719's exporting fix.

However, MSWord 2016 and 2010 show bold on the output from 6.1 too. (Perhaps it would act differently if supplemental language support is installed? I only have US defaults set.)
Comment 5 Justin L 2021-01-13 11:25:07 UTC
Created attachment 168850 [details]
arabicRT61.rtf: round-tripped by LO 6.1. In MSWord, the first paragraph is bold.

It is still outstanding in 7.2+ that this round-tripped file has no bold paragraph in LibreOffice. However, it opens in Word 2016, 2003, and 2010 with the first paragraph in bold.

NEEDINFO because I want to confirm that MS Word setup for an Arabic user also shows it as bold. (That requires some extra packages installed, and I can't easily do that anymore.)