Bug 121426 - When I paste HTML text into a cell in a table, then undo it, then cells styling is now changed from previous state
Summary: When I paste HTML text into a cell in a table, then undo it, then cells styli...
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2018-11-14 20:56 UTC by ericmurp
Modified: 2019-07-17 02:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ericmurp 2018-11-14 20:56:33 UTC
Description:
When I paste HTML text into a cell in a table, then undo it (because I wanted it unformatted) then cells styling is now changed from previous state. It should revert back to previous font and bolding and size, etc

Version: 5.2.7.2
Build ID: 1:5.2.7-1+deb9u4
CPU Threads: 4; OS Version: Linux 4.9; UI Render: default; VCL: gtk3; 
Locale: en-IE (en_IE.UTF-8); Calc: group

Steps to Reproduce:
0. Take note of the current font settings in writer within a cell of a table you made.
1. Copy a google web results page.
2. Paste into a cell in a table in Writer 
3. Undo
4. Type in the cell

Actual Results:
cells font styling is now changed 

Expected Results:
It should revert back to previous font and bolding and size, etc


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Chiang Han 2018-11-29 08:24:46 UTC
Bug not reproducible in version.

Did not find the problem after following the steps.

Additional Info:
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Comment 2 Dieter Praas 2019-01-17 19:30:28 UTC
Thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 QA Administrators 2019-07-17 02:49:26 UTC
Dear ericmurp,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INSUFFICIENTDATA
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-NeedInfo-Ping