Bug 121450 - PDF: The resolution of the images after importing the PDF
Summary: PDF: The resolution of the images after importing the PDF
Status: RESOLVED DUPLICATE of bug 115811
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Insert
  Show dependency treegraph
 
Reported: 2018-11-15 20:42 UTC by Meat_12237
Modified: 2018-11-25 20:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A sample vector PDF tor repro steps (89.08 KB, application/pdf)
2018-11-16 05:29 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Meat_12237 2018-11-15 20:42:57 UTC
When I import PDF, the PDF file is converted to a low-resolution image (96 ppi).

This resolution value is currently hardcoded in vcl/source/filter/ipdf/pdfread.cxx.

Need to adjust the resolution of image that was converted.

Problem:

This low-resolution image is printed.
It is very long and unproductive to use third-party software to convert PDF to high-resolution image.

Temporary solution:

1. (if a pdf file is a vector) - Import PDF file into DRAW, then copy to WRITER.
2. (for any pdf) - Export the WRITER document with an imported PDF as PDF file. In this case, the WRITER reused the original PDF.
Comment 1 Mike Kaganski 2018-11-16 05:29:34 UTC
Created attachment 146679 [details]
A sample vector PDF tor repro steps

Original report (also the source of the PDF): [1]

Steps to reproduce:

1. Insert the attached PDF into a new text document using Insert->Image.
2. Print the resulting document.
3. Print the original PDF using a PDF reader.
4. Compare the resolution.

Additional steps:

5. In the text document from step 2, use Crop to only make some circle with number visible
6. Stretch the result to whole page

Expected results:
the quality of printout on step 3 is the same as on step 4; step 6 results in a smooth giant circle (PDF being a vector one)

Actual results:
the printout from step 3 is much lower resolution compared to step 4; step 6 gives a highly-pixelated image.

Reproducible with Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 12; OS: Windows 10.0; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group threaded

[1] http://forumooo.ru/index.php/topic,7388.0.html
Comment 2 Mike Kaganski 2018-11-16 05:32:46 UTC
IMO, it would be great if (1) the resolution of the generated image for the imported PDF fitted the output device (-> it would regenerate for each output device, e.g., on print); and (2) it would auto-regenerate to produce the desired result upon object manipulations, like scaling.
Comment 3 V Stuart Foote 2018-11-25 20:11:54 UTC

*** This bug has been marked as a duplicate of bug 115811 ***