Download it now!
Bug 121462 - VIEWING ODT Position relative to something moves the TextBox
Summary: VIEWING ODT Position relative to something moves the TextBox
Status: RESOLVED DUPLICATE of bug 84691
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-16 12:39 UTC by NISZ LibreOffice Team
Modified: 2019-01-24 18:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file saved by Writer (9.15 KB, application/vnd.oasis.opendocument.text)
2018-11-16 12:40 UTC, NISZ LibreOffice Team
Details
The file saved by Writer – with the moved textbox (9.16 KB, application/vnd.oasis.opendocument.text)
2018-11-16 12:40 UTC, NISZ LibreOffice Team
Details
Screenshot with the textbox in original position (95.22 KB, image/png)
2018-11-16 12:41 UTC, NISZ LibreOffice Team
Details
Screenshot with the moved textbox (95.52 KB, image/png)
2018-11-16 12:41 UTC, NISZ LibreOffice Team
Details
How the Position and size dialog looks like (44.00 KB, image/png)
2018-12-12 18:13 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-11-16 12:39:44 UTC
Description:
Change the type of position from absolute to relative moves the textbox in the shape into wrong position.

Steps to Reproduce:
1. Insert a shape.
2. Add a textbox to the shape.
3. Position the shape to paragraph text area from left 0 and from top 0. (Shape-TextBox-Absolute.odt, Shape-TextBox-Absolute.PNG)
4. Change the position type to left and top. (Shape-TextBox-Relative.odt, Shape-TextBox-Relative.PNG)

Actual Results:
Actual results: The textbox in the shape moves to down and to right in the right bottom corner of the shape.

Expected Results:
Expected results: The textbox does not move.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-11-16 12:40:25 UTC
Created attachment 146688 [details]
The original file saved by Writer
Comment 2 NISZ LibreOffice Team 2018-11-16 12:40:45 UTC
Created attachment 146689 [details]
The file saved by Writer – with the moved textbox
Comment 3 NISZ LibreOffice Team 2018-11-16 12:41:04 UTC
Created attachment 146690 [details]
Screenshot with the textbox in original position
Comment 4 NISZ LibreOffice Team 2018-11-16 12:41:21 UTC
Created attachment 146691 [details]
Screenshot with the moved textbox
Comment 5 Durgapriyanka 2018-12-07 18:46:41 UTC
Thank you for reporting the bug. I can confirm that the bug is present in 

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group threaded
Comment 6 Xisco Faulí 2018-12-12 18:13:36 UTC
Created attachment 147476 [details]
How the Position and size dialog looks like

What do you mean in step 4: 4. Change the position type to left and top. (Shape-TextBox-Relative.odt, Shape-TextBox-Relative.PNG) ??

In my screenshot, it's set from left and from top, do you mean that?
Comment 7 Regina Henschel 2018-12-12 19:23:24 UTC
I guess it is the same problem as anchored to page, see bug 84691.
Comment 8 Buovjaga 2019-01-24 17:48:11 UTC
Assuming so -> closing as dupe

*** This bug has been marked as a duplicate of bug 84691 ***