Download it now!
Bug 121515 - DOCX TextBox in Shape is not rotated
Summary: DOCX TextBox in Shape is not rotated
Status: RESOLVED DUPLICATE of bug 82627
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2018-11-19 10:30 UTC by NISZ LibreOffice Team
Modified: 2019-10-17 12:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file saved by MS Word (21.76 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-19 10:31 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document in MS Word 365 (91.89 KB, image/png)
2018-11-19 10:31 UTC, NISZ LibreOffice Team
Details
Screenshot of the document in LibreOffice Writer (89.15 KB, image/png)
2018-11-19 10:32 UTC, NISZ LibreOffice Team
Details
How it looks in LibreOffice 6.2 beta2 (18.38 KB, image/png)
2018-11-19 17:53 UTC, Xisco Faulí
Details
another sample (15.12 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-10-17 12:49 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-11-19 10:30:57 UTC
Description:
The textbox in the shape is not turned, but the shape is turned, instead of being turned both.

Steps to Reproduce:
1. Insert a textbox in MS Word 365.
2. Turn it abaut 45 degree. (Shape-TextBox.PNG)
3. Save the document into .docx format. (Shape-Textbox.docx)
4. Open the .docx file with LibreOffice Writer. (Shape-Textbox-View.PNG)

Actual Results:
The textbox in the shape is not turned, but the shape is turned.

Expected Results:
Even the textbox is turned similar to the shape.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-11-19 10:31:29 UTC
Created attachment 146761 [details]
The original file saved by MS Word
Comment 2 NISZ LibreOffice Team 2018-11-19 10:31:47 UTC
Created attachment 146762 [details]
Screenshot of the original document in MS Word 365
Comment 3 NISZ LibreOffice Team 2018-11-19 10:32:04 UTC
Created attachment 146763 [details]
Screenshot of the document in LibreOffice Writer
Comment 4 Xisco Faulí 2018-11-19 17:53:25 UTC
Created attachment 146801 [details]
How it looks in LibreOffice 6.2 beta2

how it looks in

Version: 6.2.0.0.beta1+
Build ID: 268364e35100b559f42d8c02b930c5cca1c84be7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

the only problem I see is the text not rotated but the background is fine
Comment 5 Xisco Faulí 2018-11-19 17:56:32 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 6 Xisco Faulí 2019-10-17 12:49:55 UTC
Created attachment 155086 [details]
another sample
Comment 7 Xisco Faulí 2019-10-17 12:52:29 UTC
This clearly seems like a dupe of bug 82627

*** This bug has been marked as a duplicate of bug 82627 ***