Bug 121554 - Crash on file-opening
Summary: Crash on file-opening
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, perf, regression
Depends on:
Blocks: File-Opening
  Show dependency treegraph
 
Reported: 2018-11-20 14:32 UTC by Telesto
Modified: 2019-04-02 15:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (28.20 KB, application/vnd.oasis.opendocument.text)
2018-11-20 14:32 UTC, Telesto
Details
bt at random (9.76 KB, text/plain)
2018-11-20 19:56 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-11-20 14:32:09 UTC
Description:
Crash on file-opening

Steps to Reproduce:
1. Open the attached file
2. Wait until crash -> If not try again in safe-mode 

Happens frequently but not always

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: d71ea82055a6a304493c7eaa90809a348e23784d
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-11-19_03:25:07
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2018-11-20 14:32:23 UTC
Created attachment 146839 [details]
Example file
Comment 2 Dieter Praas 2018-11-20 14:45:44 UTC
No crash (I only treid once), but LO becomes unresponsive

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded
Comment 3 Telesto 2018-11-20 14:46:54 UTC
(In reply to Dieter Praas from comment #2)
> No crash (I only treid once), but LO becomes unresponsive
> 
> Version: 6.2.0.0.beta1 (x64)
> Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
> CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> Locale: en-US (de_DE); UI-Language: en-GB
> Calc: threaded

First unresponsive for while & crash follows
Comment 4 raal 2018-11-20 17:04:16 UTC
Confirm with Version: 6.3.0.0.alpha0+ (x64)
Build ID: ef2dfe4d54e1383b1f757f659f9cd1e13d12fba4
CPU threads: 1; OS: Windows 6.1; UI render: default; VCL: win;
Comment 5 raal 2018-11-20 18:50:56 UTC
Seems to be regression: works on linux, LO 4.1, but not on LO 6.2
Comment 6 Julien Nabet 2018-11-20 19:56:25 UTC
Created attachment 146848 [details]
bt at random

I don't reproduce the crash just the hanging (I waited about a minute).

I retrieved a bt at random.
Comment 7 Xisco Faulí 2018-11-21 11:42:44 UTC
I can't reproduce the crash in

Version: 6.2.0.0.beta1+
Build ID: d6ba6e4d31b872a175146f20cfb625cd520d7dc0
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

@Raal, could you please bisect the crash ?
Comment 8 Hung-Shin,Tsai 2018-11-29 09:31:42 UTC
partly confirm (Lo hanged,not crashed) with following condition

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded

On my test,LO writer became unresponsive for a while,but fully recovered after about 1.5minutes, so I assume that the condition is not all related to bugs in the program but also with personal hardware condition.
Comment 9 Xisco Faulí 2019-04-01 11:39:55 UTC
Not reproducible in

Version: 6.3.0.0.alpha0+
Build ID: d31d77b7199ecc9a7edc899d9703e9da52d5cbd1
CPU threads: 1; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-04-01_00:04:09
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded

@Raal, @Telesto, still reproducible in master ?
Comment 10 Telesto 2019-04-01 15:08:33 UTC
No crash; 
Version: 6.3.0.0.alpha0+
Build ID: 8d45d5ee399d0148672e79c379f5d29e1c8ba6f3
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-03-29_01:02:58
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

Probably because of the improvements M. Stahl made to table layouting
Still quite slow, though..
Comment 11 Xisco Faulí 2019-04-02 15:23:50 UTC
it takes

real	0m3,854s
user	0m2,962s
sys	0m0,314s

to open in

Version: 6.3.0.0.alpha0+
Build ID: 3b518953a8141b0d5043c2f3996a92956fdc3a47
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

based on comment 10, closing as RESOLVED WORKSFORME