Download it now!
Bug 121556 - Add button in tabbed mode
Summary: Add button in tabbed mode
Status: RESOLVED DUPLICATE of bug 101513
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-20 16:15 UTC by Fabián de Jesús Paniagua Miranda
Modified: 2018-11-22 08:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabián de Jesús Paniagua Miranda 2018-11-20 16:15:28 UTC
Description:
I would like to add a button to the tool bar with right click int the tabbed mode of user interface, just like I can do it in the default bar.

Steps to Reproduce:
1.Choose de tabbed mode of use interface
2.Try to add a button with right
3.

Actual Results:
I can't

Expected Results:
I expect that I can add a button to the tool bar with right click


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Drew Jensen 2018-11-20 17:05:39 UTC
I would make this two different issues. 

First is the ability to add buttons into a notebook tab via the customize dialog.
(I believe there is already an issue on that)

Second add the context menu to the notebook bar as an interface to the customize dialog. 

So what I would suggest is changing the Summary to deal with the context menu and I would confirm that.
Comment 2 Heiko Tietze 2018-11-21 07:46:44 UTC
Let's make it a duplicate then.

*** This bug has been marked as a duplicate of bug 101513 ***
Comment 3 Drew Jensen 2018-11-21 13:26:20 UTC
(In reply to Heiko Tietze from comment #2)
> Let's make it a duplicate then.
> 
> *** This bug has been marked as a duplicate of bug 101513 ***

I would of thought you would prefer to change the summary to deal with how to launch the Customize dialog since that seems to have slipped through the cracks during the time this feature was in experimental stage. 

Seriously since there no such thing, that I can see, as requirements documents any longer Bugzilla is the only thing you have to track requirements and the UI for getting to the Customize Dialog is a requirement.
Comment 4 Heiko Tietze 2018-11-22 08:13:19 UTC
(In reply to Drew Jensen from comment #3)
> I would of thought you would prefer to change the summary to deal with how
> to launch the Customize dialog since that seems to have slipped through the
> cracks during the time this feature was in experimental stage. 
> 
> Seriously since there no such thing, that I can see, as requirements
> documents any longer Bugzilla is the only thing you have to track
> requirements and the UI for getting to the Customize Dialog is a requirement.

Don't see why standard toolbar or notebookbar would need direct access to the customization. This feature is not so often used that it needs to get exposed on the primary UI.
And we should also not just duplicate the standard toolbar, so the on-the-fly customization (button on/off) is just not available. It was/is a vehicle for the standard toolbar to circumvent the inconvenient customization that was improved greatly in the last release.
But the last piece in the request, the customization in general, is required and has a duplicate.